Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21074

Git Client plugin fails to install on fresh Jenkins installation

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: git-client-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 13.01
    • Similar Issues:

      Description

      When installing GitHub Plugin that requires Git Client Plugin, plugin installation will fail with following error

      java.io.IOException: Failed to dynamically deploy this plugin
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1304)
      at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1103)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
      at java.util.concurrent.FutureTask.run(FutureTask.java:266)
      at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:104)
      at java.lang.Thread.run(Thread.java:744)
      Caused by: java.io.IOException: Failed to initialize git-client plugin
      at hudson.PluginManager.dynamicLoad(PluginManager.java:451)
      at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1300)
      ... 5 more
      Caused by: org.jvnet.hudson.reactor.ReactorException: java.lang.Error: java.lang.reflect.InvocationTargetException
      at org.jvnet.hudson.reactor.Reactor.execute(Reactor.java:269)
      at jenkins.InitReactorRunner.run(InitReactorRunner.java:44)
      at hudson.PluginManager.dynamicLoad(PluginManager.java:449)
      ... 6 more
      Caused by: java.lang.Error: java.lang.reflect.InvocationTargetException
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:109)
      at hudson.init.TaskMethodFinder$TaskImpl.run(TaskMethodFinder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      ... 1 more
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:483)
      at hudson.init.TaskMethodFinder.invoke(TaskMethodFinder.java:105)
      ... 7 more
      Caused by: java.lang.ArrayIndexOutOfBoundsException: -1
      at com.thoughtworks.xstream.core.util.OrderRetainingMap.entrySet(OrderRetainingMap.java:77)
      at java.util.HashMap.putMapEntries(HashMap.java:511)
      at java.util.HashMap.putAll(HashMap.java:784)
      at com.thoughtworks.xstream.core.util.OrderRetainingMap.<init>(OrderRetainingMap.java:36)
      at com.thoughtworks.xstream.converters.reflection.FieldDictionary.buildMap(FieldDictionary.java:135)
      at com.thoughtworks.xstream.converters.reflection.FieldDictionary.fieldsFor(FieldDictionary.java:76)
      at com.thoughtworks.xstream.converters.reflection.PureJavaReflectionProvider.visitSerializableFields(PureJavaReflectionProvider.java:127)
      at hudson.util.RobustReflectionConverter.doMarshal(RobustReflectionConverter.java:143)
      at hudson.util.RobustReflectionConverter.marshal(RobustReflectionConverter.java:102)
      at com.thoughtworks.xstream.core.AbstractReferenceMarshaller.convert(AbstractReferenceMarshaller.java:69)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:58)
      at com.thoughtworks.xstream.core.TreeMarshaller.convertAnother(TreeMarshaller.java:43)
      at com.thoughtworks.xstream.core.TreeMarshaller.start(TreeMarshaller.java:82)
      at com.thoughtworks.xstream.core.AbstractTreeMarshallingStrategy.marshal(AbstractTreeMarshallingStrategy.java:37)
      at com.thoughtworks.xstream.XStream.marshal(XStream.java:898)
      at com.thoughtworks.xstream.XStream.marshal(XStream.java:887)
      at com.thoughtworks.xstream.XStream.toXML(XStream.java:860)
      at hudson.XmlFile.write(XmlFile.java:182)
      at hudson.model.Descriptor.save(Descriptor.java:758)
      at hudson.plugins.git.GitTool.onLoaded(GitTool.java:106)
      ... 12 more

        Attachments

          Activity

          peter_budo Peter Miklosko added a comment -

          Nicolas De Loof let me know if you need anymore details in regards of this bug

          chrislovsund Christian Lövsund added a comment -

          I think I got the same when running jenkins with JDK 8.
          Worked fine after switching to JDK 7u45.

          peter_budo Peter Miklosko added a comment -

          At the end of the day it was indeed jdk 8 issue.

          peter_budo Peter Miklosko added a comment -

          It appears that problem was in JDK 8 that got for some reason installed on server with one of the updates.

          javapriyan Karthikeyan Annamalai added a comment -

          Facing the same issue in following configuration as well.
          OS : Windows 7
          JDK: 1.7.0_55


            People

            • Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              peter_budo Peter Miklosko
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: