Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21169

ClassCastException from MultiSCMRevisionState to CloneWorkspaceSCM

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: multiple-scms-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.509.4 running on Windows Server 2008 R2 64-bit, Multiple SCMs plugin 0.2, Clone Workspace SCM Plug-in 0.6
    • Similar Issues:

      Description

      The "Multiple SCMs Polling Log" shows for me (see [1]):

      ERROR: Failed to record SCM polling for hudson.model.FreeStyleProject@1c9f55c[mingwGitDevEnv-test-git]
      java.lang.ClassCastException: org.jenkinsci.plugins.multiplescms.MultiSCMRevisionState cannot be cast to hudson.plugins.cloneworkspace.CloneWorkspaceSCM$CloneWorkspaceSCMRevisionState
      	at hudson.plugins.cloneworkspace.CloneWorkspaceSCM.compareRemoteRevisionWith(CloneWorkspaceSCM.java:291)
      	at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
      	at hudson.scm.SCM.poll(SCM.java:373)
      	at org.jenkinsci.plugins.multiplescms.MultiSCM.compareRemoteRevisionWith(MultiSCM.java:91)
      	at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
      	at hudson.scm.SCM.poll(SCM.java:373)
      	at hudson.model.AbstractProject.pollWithWorkspace(AbstractProject.java:1549)
      	at hudson.model.AbstractProject._poll(AbstractProject.java:1521)
      	at hudson.model.AbstractProject.poll(AbstractProject.java:1455)
      	at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:439)
      	at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:468)
      	at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      	at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      	at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      	at java.util.concurrent.FutureTask.run(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      	at java.lang.Thread.run(Unknown Source)
      

      Maybe this (also) is an issue with the Clone Workspace SCM Plug-in?

      [1] http://mingwgitdevenv.cloudapp.net/job/mingwGitDevEnv-test-git/scmPollLog/?auto_refresh=false

        Attachments

          Issue Links

            Activity

            rodrigc Craig Rodrigues added a comment -

            Duplicate of JENKINS-27638

            sschuberth Sebastian Schuberth added a comment - - edited

            Craig Rodrigues What makes you think this is a dupe of JENKINS-27638 as

            1) the stack trace is different, i.e. the exception occurs in another code area,
            2) this is about casting from MultiSCMRevisionState while JENKINS-27638 is about casting to MultiSCMRevisionState.

            danielbeck Daniel Beck added a comment -

            Craig Rodrigues Could you release Multiple SCMs plugin with the fix for JENKINS-27638? This way Sebastian Schuberth could test whether its fix also resolves this issue.


              People

              • Assignee:
                kbell Kevin Bell
                Reporter:
                sschuberth Sebastian Schuberth
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: