Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21368

After installation of Promoted Builds Plugin some jobs that are NOT using plugin got FATALs.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Component/s: promoted-builds-plugin
    • Labels:
      None
    • Environment:
      Linux, Jenkins 1.541, Promoted build plugin 2.14.
    • Similar Issues:

      Description

      Jobs that are NOT using promotion feature got FATAL errors:

      00:00:00.059 FATAL: hudson/plugins/promoted_builds/Promotion
      00:00:00.060 java.lang.NoClassDefFoundError: hudson/plugins/promoted_builds/Promotion
      00:00:00.060 at hudson.plugins.parameterizedtrigger.BuildTriggerConfig.createUpstreamCause(BuildTriggerConfig.java:435)
      00:00:00.060 at hudson.plugins.parameterizedtrigger.BuildTriggerConfig.schedule(BuildTriggerConfig.java:448)
      00:00:00.060 at hudson.plugins.parameterizedtrigger.BlockableBuildTriggerConfig.schedule(BlockableBuildTriggerConfig.java:72)
      00:00:00.060 at hudson.plugins.parameterizedtrigger.BuildTriggerConfig.perform2(BuildTriggerConfig.java:379)
      00:00:00.060 at hudson.plugins.parameterizedtrigger.BlockableBuildTriggerConfig.perform2(BlockableBuildTriggerConfig.java:57)
      00:00:00.060 at hudson.plugins.parameterizedtrigger.TriggerBuilder.perform(TriggerBuilder.java:85)
      00:00:00.060 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      00:00:00.060 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785)
      00:00:00.060 at hudson.model.Build$BuildExecution.build(Build.java:199)
      00:00:00.060 at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      00:00:00.060 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:566)
      00:00:00.060 at hudson.model.Run.execute(Run.java:1677)
      00:00:00.060 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      00:00:00.060 at hudson.model.ResourceController.execute(ResourceController.java:88)
      00:00:00.060 at hudson.model.Executor.run(Executor.java:230)

        Attachments

          Activity

          habdank Seweryn Habdank-Wojewodzki added a comment -

          It seems plugin collide with job that contains "Trigger/call builds on the other projects".
          After removal of that build part job is working, but ofcourse that is not desired.
          And again job DOES NOT contain enabled "Promote builds when...", what makes error very strange.
          How not enabled feature can collide with other features .

          oleg_nenashev Oleg Nenashev added a comment -

          Seems there is a conflict between libraries during the classloading. I cannot imagine other case, but these plugins seem to be working correctly together in the latest releases. It needs to be confirmed BTW.

          oleg_nenashev Oleg Nenashev added a comment -

          Cannot reproduce on the latest plugin versions. If it still happens, please reopen the issue


            People

            • Assignee:
              Unassigned
              Reporter:
              habdank Seweryn Habdank-Wojewodzki
            • Votes:
              3 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: