Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21460

TFS plugin throws NumberFormatException

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Component/s: tfs-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 12.10 (BitNami Jenkins 1.547-0), TEE-CLC 11
    • Similar Issues:

      Description

      When I do a poll from Visual Studio Online I get the following Exception:

      No history entries were found for the item and version combination specified.
      FATAL: For input string: ""
      java.lang.NumberFormatException: For input string: ""
      at java.lang.NumberFormatException.forInputString(Unknown Source)
      at java.lang.Integer.parseInt(Unknown Source)
      at hudson.plugins.tfs.model.Project.getRemoteChangesetVersion(Project.java:200)
      at hudson.plugins.tfs.model.Project.getRemoteChangesetVersion(Project.java:214)
      at hudson.plugins.tfs.TeamFoundationServerScm.checkout(TeamFoundationServerScm.java:189)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:1415)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:652)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:561)
      at hudson.model.Run.execute(Run.java:1678)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:231)

        Attachments

          Issue Links

            Activity

            ndsingh Nagendra Singh added a comment -

            I am getting the same error. Anyone got any idea?

            hetzandreas Andreas Hetz added a comment - - edited

            I have the same problem, please fix it. Thank you. If you need any kind of help, please ping me.

            ndsingh Nagendra Singh added a comment - - edited

            I was able to make this work. Like Michael said you need to append the name of the collection. Once you do this, you might see another error. Reason: You have already created a workspace for http://tfsprod:8080/tfs. So, delete the current job and create it again. This time instead of http://tfsprod:8080/tfs use http://tfsprod:8080/tfs/DefaultCollection. It should work.

            zalimgandhera ahmed daniel added a comment -

            I have a samilar issue but mine comes randomly on builds which were working fine before and disappears the next time I run the same job without making any changes.
            I have the collections appended in TFS server URL in Jenkins.
            Building remotely on BuildMachine (VisualStudio) in workspace c:\Jenkins\InteractiveLibraries
            FATAL: java.lang.NumberFormatException: For input string: ""
            java.lang.RuntimeException: java.lang.NumberFormatException: For input string: ""
            at hudson.plugins.tfs.model.Server.execute(Server.java:226)
            at hudson.plugins.tfs.model.Project.extractChangesetNumber(Project.java:275)
            at hudson.plugins.tfs.model.Project.getRemoteChangesetVersion(Project.java:271)
            at hudson.plugins.tfs.model.Project.getRemoteChangesetVersion(Project.java:287)
            at hudson.plugins.tfs.TeamFoundationServerScm.recordWorkspaceChangesetVersion(TeamFoundationServerScm.java:359)
            at hudson.plugins.tfs.TeamFoundationServerScm.checkout(TeamFoundationServerScm.java:308)
            at hudson.model.AbstractProject.checkout(AbstractProject.java:1269)
            at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:604)
            at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
            at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
            at hudson.model.Run.execute(Run.java:1741)
            at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
            at hudson.model.ResourceController.execute(ResourceController.java:98)
            at hudson.model.Executor.run(Executor.java:410)
            Caused by: java.lang.NumberFormatException: For input string: ""
            at java.lang.NumberFormatException.forInputString(Unknown Source)
            at java.lang.Long.parseLong(Unknown Source)
            at java.lang.Long.parseLong(Unknown Source)
            at java.text.DigitList.getLong(Unknown Source)
            at java.text.DecimalFormat.parse(Unknown Source)
            at java.text.SimpleDateFormat.subParse(Unknown Source)
            at java.text.SimpleDateFormat.parse(Unknown Source)
            at java.text.DateFormat.parse(Unknown Source)
            at com.microsoft.tfs.util.datetime.LenientDateTimeParser.parseExtended(LenientDateTimeParser.java:285)
            at com.microsoft.tfs.util.datetime.LenientDateTimeParser.parse(LenientDateTimeParser.java:365)
            at com.microsoft.tfs.core.clients.versioncontrol.specs.version.DateVersionSpec.<init>(DateVersionSpec.java:51)
            at com.microsoft.tfs.core.clients.versioncontrol.specs.version.VersionSpec.parseSingleVersionFromSpec(VersionSpec.java:197)
            at hudson.plugins.tfs.commands.RemoteChangesetVersionCommand.call(RemoteChangesetVersionCommand.java:59)
            at hudson.plugins.tfs.commands.RemoteChangesetVersionCommand.call(RemoteChangesetVersionCommand.java:33)
            at hudson.remoting.UserRequest.perform(UserRequest.java:120)
            at hudson.remoting.UserRequest.perform(UserRequest.java:48)
            at hudson.remoting.Request$2.run(Request.java:332)
            at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
            at java.util.concurrent.FutureTask.run(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at hudson.remoting.Engine$1$1.run(Engine.java:85)
            at java.lang.Thread.run(Unknown Source)
            at ......remote call to BuildMachine(Native Method)
            at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
            at hudson.remoting.UserResponse.retrieve(UserRequest.java:253)
            at hudson.remoting.Channel.call(Channel.java:781)
            at hudson.plugins.tfs.model.Server.execute(Server.java:222)
            ... 13 more

            kelliejos Kellie Jos added a comment -

            Thank you for using the tfs-plugin. It appears that your issue was found in an older version of the plugin. There have been a number of improvements made in the recent releases that may have resolved your issue. Please update to the most recent 5.126.0 release. If your issue persists, please open a new ticket and we will investigate.


              People

              • Assignee:
                dastahel David Staheli
                Reporter:
                gustavgahm Gustav Gahm
              • Votes:
                6 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: