Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21532

Broken HTML in job configuration page

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
      xunit-plugin 1.80
    • Similar Issues:

      Description

      <br><br> before Extra Configuration block is placed in bad place in HTML like this:

      ...
             <tr>
                <td class="setting-leftspace"> </td>
                <td class="setting-name">Choose your threshold mode</td>
                <td class="setting-main">
                 <input name="thresholdMode" value="1" type="radio" checked="true" />
                 <label class="attach-previous">Use a number of tests</label>
                 <br />
                 <input name="thresholdMode" value="2" type="radio" /><label class="attach-previous">Use a percent of tests</label>
                </td>
              </tr>
              <tr class="validation-error-area"><td colspan="2"></td><td></td></tr>
            </tbody></table>
          </td></tr>
        </td></tr>
        <br /><br />  <!-- This is wrong HTML!!!! -->
        <tr><td colspan="3">
          <tr>
            <td></td>
            <td></td>
      ...
      

      This happens used as both builder and publisher.

      Especially combined with Flexible Publish Plugin, this cause drop-down lists not to work (JENKINS-21497).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                gbois Gregory Boissinot
                Reporter:
                ikedam ikedam
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: