Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2174

Violations Plugin throws NPE

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: violations-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I am attempting to use Hudson 1.243 with Violations 0.7.0 on a Maven2 job to
      have Violations aggregate my Maven2 FindBugs, PMD, and CPD reports.
      Unfortunately, though my job successfully builds, when I select the "Violations"
      link on the left-side bar of my job, Hudson returns an HTTP 500 error and a
      stacktrace that shows an NPE:
      Status Code: 500
      Exception:
      Stacktrace:

      java.lang.NullPointerException at
      hudson.plugins.violations.hudson.maven.ViolationsAggregatedReport.init(ViolationsAggregatedReport.java:60)
      at
      hudson.plugins.violations.hudson.maven.ViolationsAggregatedReport.ViolationsAggregatedReport.java:28)
      at
      hudson.plugins.violations.hudson.maven.ViolationsMavenAggregatedBuildAction.getReport(ViolationsMavenAggregatedBuildAction.java:54)
      at
      hudson.plugins.violations.hudson.maven.ViolationsMavenAggregatedBuildAction.getReport(ViolationsMavenAggregatedBuildAction.java:23)
      at
      hudson.plugins.violations.hudson.AbstractViolationsProjectAction.getViolationsAction(AbstractViolationsProjectAction.java:116)
      at
      hudson.plugins.violations.hudson.AbstractViolationsProjectAction.getTarget(AbstractViolationsProjectAction.java:73)

        Attachments

          Activity

          peterkittreilly peterkittreilly added a comment -

          Fixed in version 0.7.3, thanks to all for checking.

          abarbieri Andrea Barbieri added a comment -

          Hello,

          still experiencing the same issue with a FreeStyle job on Hudson 1.301 and
          Violations plugin 0.7.3 (either on a Master or a Slave node)

          29-Apr-2009 16:57:07 hudson.ExpressionFactory2$JexlExpression evaluate
          WARNING: Caught exception evaluating: cs.msgAnnotated. Reason:
          java.lang.reflect.InvocationTargetException
          java.lang.reflect.InvocationTargetException
          at sun.reflect.GeneratedMethodAccessor1397.invoke(Unknown Source)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
          at java.lang.reflect.Method.invoke(Unknown Source)
          at org.apache.commons.jexl.util.PropertyExecutor.execute(PropertyExecutor.java:125)
          at
          org.apache.commons.jexl.util.introspection.UberspectImpl$VelGetterImpl.invoke(UberspectImpl.java:314)
          at
          org.apache.commons.jexl.parser.ASTArrayAccess.evaluateExpr(ASTArrayAccess.java:185)
          at org.apache.commons.jexl.parser.ASTIdentifier.execute(ASTIdentifier.java:75)
          at org.apache.commons.jexl.parser.ASTReference.execute(ASTReference.java:83)
          at org.apache.commons.jexl.parser.ASTReference.value(ASTReference.java:57)
          at
          org.apache.commons.jexl.parser.ASTReferenceExpression.value(ASTReferenceExpression.java:51)
          at org.apache.commons.jexl.ExpressionImpl.evaluate(ExpressionImpl.java:80)
          at hudson.ExpressionFactory2$JexlExpression.evaluate(ExpressionFactory2.java:71)
          at org.apache.commons.jelly.impl.ExpressionScript.run(ExpressionScript.java:66)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.tags.core.ForEachTag.doTag(ForEachTag.java:150)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.tags.core.JellyTag.doTag(JellyTag.java:45)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.kohsuke.stapler.jelly.IncludeTag.doTag(IncludeTag.java:114)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at
          org.kohsuke.stapler.jelly.CustomTagLibrary$StaplerDynamicTag$1.run(CustomTagLibrary.java:147)
          at org.apache.commons.jelly.tags.define.InvokeBodyTag.doTag(InvokeBodyTag.java:91)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.tags.core.IfTag.doTag(IfTag.java:42)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.tags.core.JellyTag.doTag(JellyTag.java:45)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:81)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at
          org.kohsuke.stapler.jelly.CustomTagLibrary$StaplerDynamicTag$1.run(CustomTagLibrary.java:147)
          at org.apache.commons.jelly.tags.define.InvokeBodyTag.doTag(InvokeBodyTag.java:91)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
          at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.tags.core.JellyTag.doTag(JellyTag.java:45)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:81)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
          at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
          at org.apache.commons.jelly.tags.core.JellyTag.doTag(JellyTag.java:45)
          at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
          at
          org.kohsuke.stapler.jelly.DefaultScriptInvoker.invokeScript(DefaultScriptInvoker.java:29)
          at org.kohsuke.stapler.jelly.JellyFacet$1.dispatch(JellyFacet.java:51)
          at org.kohsuke.stapler.Stapler.invoke(Stapler.java:486)
          at org.kohsuke.stapler.MetaClass$12.dispatch(MetaClass.java:318)
          at org.kohsuke.stapler.Stapler.invoke(Stapler.java:486)
          at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:186)
          at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          at org.kohsuke.stapler.Stapler.invoke(Stapler.java:486)
          at org.kohsuke.stapler.MetaClass$6.doDispatch(MetaClass.java:186)
          at org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
          at org.kohsuke.stapler.Stapler.invoke(Stapler.java:486)
          at org.kohsuke.stapler.Stapler.invoke(Stapler.java:404)
          at org.kohsuke.stapler.Stapler.service(Stapler.java:117)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
          at
          org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
          at
          org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:91)
          at
          org.jvnet.hudson.plugins.greenballs.GreenBallFilter.doFilter(GreenBallFilter.java:38)
          at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:94)
          at hudson.util.PluginServletFilter.doFilter(PluginServletFilter.java:83)
          at
          org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at
          org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:84)
          at hudson.plugins.audit_trail.AuditTrailFilter.doFilter(AuditTrailFilter.java:35)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:84)
          at
          hudson.security.UnwrapSecurityExceptionFilter.doFilter(UnwrapSecurityExceptionFilter.java:51)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at
          org.acegisecurity.ui.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:166)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at
          org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at
          org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at
          org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:271)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at
          org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at
          org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:249)
          at
          hudson.security.HttpSessionContextIntegrationFilter2.doFilter(HttpSessionContextIntegrationFilter2.java:66)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:76)
          at hudson.security.ChainedServletFilter$1.doFilter(ChainedServletFilter.java:87)
          at hudson.security.ChainedServletFilter.doFilter(ChainedServletFilter.java:76)
          at hudson.security.HudsonFilter.doFilter(HudsonFilter.java:155)
          at
          org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
          at
          org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
          at
          org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
          at
          org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
          at
          org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
          at org.jstripe.tomcat.probe.Tomcat55AgentValve.invoke(Tomcat55AgentValve.java:20)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
          at
          org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
          at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
          at
          org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
          at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
          at java.lang.Thread.run(Unknown Source)
          Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
          at hudson.MarkupText$SubText.start(MarkupText.java:126)
          at hudson.MarkupText$SubText.group(MarkupText.java:155)
          at
          hudson.plugins.bugzilla.BugzillaChangelogAnnotator.getId(BugzillaChangelogAnnotator.java:19)
          at
          hudson.plugins.bugzilla.BugzillaChangelogAnnotator.annotate(BugzillaChangelogAnnotator.java:44)
          at hudson.scm.ChangeLogSet$Entry.getMsgAnnotated(ChangeLogSet.java:150)
          ... 147 more

          29-Apr-2009 16:56:47 hudson.model.Run run
          INFO: freestyle-ci #727 main build action completed: SUCCESS

          many thanks
          andrea

          peterkittreilly peterkittreilly added a comment -

          I am confused - 1) the stack trace does not have any violations classes
          in it, and 2) it is not good bugzilla etiquette to reopen a bugzilla report
          with a different bug - the original one in this case was a specific issue
          with M2 job support in the violations plugin.

          abarbieri Andrea Barbieri added a comment -

          Hello,

          first of all an apology. I have just noticed the last two lines of the
          exception trace saying hudson.plugins.bugzilla.BugzillaChangelogAnnotator.getId.
          I was focusing on the top ones which reported hudson.ExpressionFactory2
          $JexlExpression, matching other comments. Hence wrongly reopening the issue
          believing there was a genuine need to report/reopen the issue.

          Now fully aware of this I will open a new issue related to the bugzilla plugin.

          many thanks for the patience,
          andrea

          peterkittreilly peterkittreilly added a comment -

          No problem, Peter


            People

            • Assignee:
              peterkittreilly peterkittreilly
              Reporter:
              anurup anurup
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: