Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21905

intermittent Failed to archive artifacts: Failed to extract caused by Unexpected end of ZLIB input stream

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      Since approximately 1/30 we have seen 15 very intermittent archiving failures in Jenkins, of the form:

      Archiving artifacts
      ERROR: Failed to archive artifacts: versions/**, archive/**
      java.io.IOException: Failed to extract /foo/bar/slave/workspace/someJob/transfer of 7 files
      	at hudson.FilePath.readFromTar(FilePath.java:2088)
      	at hudson.FilePath.copyRecursiveTo(FilePath.java:2000)
      	at jenkins.model.StandardArtifactManager.archive(StandardArtifactManager.java:57)
      	at hudson.tasks.ArtifactArchiver.perform(ArtifactArchiver.java:140)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:784)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:756)
      	at hudson.model.Build$BuildExecution.post2(Build.java:183)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:705)
      	at hudson.model.Run.execute(Run.java:1695)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:231)
      Caused by: java.io.EOFException: Unexpected end of ZLIB input stream
      	at com.jcraft.jzlib.InflaterInputStream.fill(InflaterInputStream.java:186)
      	at com.jcraft.jzlib.InflaterInputStream.read(InflaterInputStream.java:106)
      	at org.apache.tools.tar.TarBuffer.readBlock(TarBuffer.java:257)
      	at org.apache.tools.tar.TarBuffer.readRecord(TarBuffer.java:223)
      	at hudson.org.apache.tools.tar.TarInputStream.getNextEntry(TarInputStream.java:228)
      	at hudson.FilePath.readFromTar(FilePath.java:2066)
      	... 12 more
      Build step 'Archive the artifacts' changed build result to FAILURE
      

      We definitely have seen this running 1.548 and later, especially with 1.549. I cannot confirm if we saw it with 1.547 or earlier, but if so, I think it was less frequent. It seems to be a relatively new issue we are seeing.

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            core/src/main/java/hudson/tasks/ArtifactArchiver.java
            http://jenkins-ci.org/commit/jenkins/7139382011b2e4f8548d796ba250f6f8c870038f
            Log:
            JENKINS-21905 Diagnose the known cause without printing stacktrace

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            core/src/main/java/hudson/tasks/ArtifactArchiver.java
            http://jenkins-ci.org/commit/jenkins/9bd9c48af3c3652aee8d0a810ecf744654259525
            Log:
            JENKINS-21905 Log the diagnosed cause just in case

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            test/src/test/java/hudson/tasks/ArtifactArchiverTest.java
            http://jenkins-ci.org/commit/jenkins/efbdac0f76378105d4b2ada8d9b639b65a41cf3b
            Log:
            JENKINS-21905 Skip unittest on windows

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Oliver Gondža
            Path:
            core/src/main/java/hudson/util/io/TarArchiver.java
            http://jenkins-ci.org/commit/jenkins/08a4c5d05ee6d91376603479b3044ecbdf759d08
            Log:
            JENKINS-21905 fix typo

            olivergondza Oliver Gondža added a comment -

            I am closing this issue as the better diagnosing facility has been put in place. If you experience what seems like a similar issue with newer core, please create a separate issue with details attached.


              People

              • Assignee:
                olivergondza Oliver Gondža
                Reporter:
                sroth Steve Roth
              • Votes:
                10 Vote for this issue
                Watchers:
                25 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: