Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22089

android userdata.img not found and skin name not valid

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Labels:
      None
    • Environment:
      jenkins 1.553, up-to-date Ubuntu 12.04 LTS on amd64, using jdk7 from distro
    • Similar Issues:

      Description

      I let the plugin install everything needed (from scratch!) and activated "run emulator" feature.

      For Android OS Version 3.2 I get:

      $ /var/lib/jenkins/tools/android-sdk/tools/android list target
      [android] Using Android SDK: /var/lib/jenkins/tools/android-sdk
      [android] Creating Android AVD: /var/lib/jenkins/.android/avd/hudson_en-US_160_WVGA_android-13.avd
      [android] /var/lib/jenkins/tools/android-sdk/tools/android create avd -f -a -c 512M -s WVGA800 -n hudson_en-US_160_WVGA_android-13 -t android-13
      Error: 'WVGA800' is not a valid skin name or size (NNNxMMM)

      [android] Could not create Android emulator: Failed to run AVD creation command
      Finished: NOT_BUILT

      For OS version 4+ I get:

      $ /var/lib/jenkins/tools/android-sdk/tools/android list target
      [android] Using Android SDK: /var/lib/jenkins/tools/android-sdk
      [android] Creating Android AVD: /var/lib/jenkins/.android/avd/hudson_en-US_160_WVGA_android-15_armeabi-v7a.avd
      [android] /var/lib/jenkins/tools/android-sdk/tools/android create avd -f -a -c 512M -s WVGA800 -n hudson_en-US_160_WVGA_android-15_armeabi-v7a -t android-15 --abi armeabi-v7a
      Error: Unable to find a 'userdata.img' file for ABI armeabi-v7a to copy into the AVD folder.

      [android] Could not create Android emulator: Failed to run AVD creation command
      Finished: NOT_BUILT

        Attachments

          Issue Links

            Activity

            marc321 Mr Cinquero added a comment -

            hmmm... looks like the command line avd manager is broken.

            marc321 Mr Cinquero added a comment - - edited

            hmmm.. AVD auto-setup now worked with OS version 2.3.3 after I had created the AVD for 4.0.3 manually...

            marc321 Mr Cinquero added a comment -

            the plugin should also add -no-audio because there is an open bug with the emulator: it enters and endless loop on headless kvm machines with more recent images....

            marc321 Mr Cinquero added a comment -

            https://code.google.com/p/android/issues/detail?id=66980

            Hint: try to omit the abi definition on the command line. Should be selected through the target.

            pradeepto Pradeepto Bhattacharya added a comment -

            Looks this issue is similar to the JENKINS-17532. Is there a way around the possible avd commandline error?

            orrc Christopher Orr added a comment -

            Closing as this is two issues: one is a duplicate of JENKINS-17532, and the other, as noted, is an Android SDK tools bug (which has since been fixed).


              People

              • Assignee:
                orrc Christopher Orr
                Reporter:
                marc321 Mr Cinquero
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: