Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: unity3d-plugin
    • Labels:
      None
    • Environment:
      Windows Master. OSX Slave Node running Unity.
      unity3d-plugin: 0.6.
    • Similar Issues:

      Description

      When executing the build on the slave, sometimes (it seems to happen when the build duration is considerable, like building for the webplayer), the plugin fails with:

      ... [NORMAL BUILD OUTOUT] ...

      LZMA 4.43 Copyright (c) 1999-2006 Igor Pavlov 2006-06-04
      Failure on remote
      java.io.IOException: Pipe broken
      at java.io.PipedInputStream.read(Unknown Source)
      at java.io.PipedInputStream.read(Unknown Source)
      at java.io.InputStream.read(Unknown Source)
      at org.jenkinsci.plugins.unity3d.io.StreamCopyThread.run(StreamCopyThread.java:64)
      ... [Jenkins internal stack trace] ...

      It fails after the LZMA compression ends (the process lasts several minutes).

        Attachments

          Issue Links

            Activity

            jspohr Johannes Spohr added a comment -

            NTP is used on both server and slaves. Clock difference is about 6 seconds between server and Unity slaves.

            lacostej lacostej added a comment -

            I think this is just a duplicate of JENKINS-23958

            lacostej lacostej added a comment - - edited

            I'll assume this is a duplicate of JENKINS-23958.

            I need more information from you guys. Please look at the information I added to JENKINS-23958 to help you create those debugging logs. I'll be happy to take a look anytime. This issue bothers me a lot Thanks!

            See https://issues.jenkins-ci.org/browse/JENKINS-23958?focusedCommentId=226618&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-226618

            lacostej lacostej added a comment -

            I have a fix for JENKINS-23958. Will be in v0.8.

            lacostej lacostej added a comment -

            Fixed in v0.8


              People

              • Assignee:
                lacostej lacostej
                Reporter:
                juan_batovi Juan Fornos
              • Votes:
                3 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: