Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22641

Jenkins no longer kills running processes after job fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Environment:
      Jenkins 1.553 or later on CentOS 6.3 with Oracle Java 7 JDK
    • Similar Issues:

      Description

      Starting at version 1.553, Jenkins no longer seems to kill running processes after a build failure.

      We have several jobs that start a Tomcat instance and run various end-to-end-tests; if the build fails Jenkins doesn't execute the shutdown scripts and we rely on the process killer to clean up the Tomcat instance.

      This can be duplicated more easily by creating a free-form job and adding two shell scripts, the first that starts a simple command such as "nohup sleep 10000 &" and the second "/bin/false". After the job exits the sleep process is still running. Prior to version 1.553, it would be killed.

      There are no log messages to indicate a problem.

      I can reproduce this on CentOS 6, Red Hat EL 5 and Red Hat EL 4, both with a job running on the local master, and on a slave node. Also tested with both 32-bit and 64-bit Oracle Java 7 JDKs.

      We're using the built-in Winstone container.

        Attachments

          Issue Links

            Activity

            jglick Jesse Glick added a comment -

            Don Bogardus then your issue is probably a distinct bug with a similar symptom but potentially distinct preconditions and root cause. Better to file it as a new ticket, with any steps to reproduce you can muster, and mark it as “blocking” this one.

            dbogardus Don Bogardus added a comment -

            Created JENKINS-26048 for similar bug returning in 1.587.

            dilipm79 Dilip Mahadevappa added a comment -

            Also see in Jenkins ver. 1.580.1
            Project type: Maven

            danielbeck Daniel Beck added a comment -

            Dilip M: That's probably JENKINS-26048. Maven project type works differently from freestyle.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            pom.xml
            src/test/java/org/jenkinsci/plugins/durabletask/BourneShellScriptTest.java
            http://jenkins-ci.org/commit/durable-task-plugin/fc48f447763cb69d6ebf7c67e54e476d9e903bbd
            Log:
            Added test for stop.
            JENKINS-22641 means that this does not work in 1.554.3, so need to bump up the dependency to 1.565.3.


              People

              • Assignee:
                schristou Steven Christou
                Reporter:
                toadnik17 Todd Perry
              • Votes:
                12 Vote for this issue
                Watchers:
                24 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: