Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22739

v1.0.6 crashes on upload with java.util.NoSuchElementException

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: hockeyapp-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.560, OSX 10.9.2, using Jenkins.app
    • Similar Issues:

      Description

      Latest version v1.0.6 crashes on upload with

      15:58:06 Uploading to HockeyApp...
      15:58:06 java.util.NoSuchElementException
      15:58:06 at org.apache.tools.ant.types.resources.FileResourceIterator.nextResource(FileResourceIterator.java:141)
      15:58:06 at org.apache.tools.ant.types.resources.FileResourceIterator.next(FileResourceIterator.java:125)
      15:58:06 at hockeyapp.HockeyappRecorder.perform(HockeyappRecorder.java:138)
      15:58:06 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      15:58:06 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:740)
      15:58:06 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:710)
      15:58:06 at hudson.model.Build$BuildExecution.post2(Build.java:182)
      15:58:06 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:659)
      15:58:06 at hudson.model.Run.execute(Run.java:1728)
      15:58:06 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      15:58:06 at hudson.model.ResourceController.execute(ResourceController.java:88)
      15:58:06 at hudson.model.Executor.run(Executor.java:231)
      15:58:06 Build step 'Upload to HockeyApp' marked build as failure

      Downgrading to 1.0.5 works as previously

        Attachments

          Activity

          ohoeltke Oliver H added a comment -

          was a duplicate of #JENKINS-22848 which is fixed by 1.1.0 (released today)


            People

            • Assignee:
              Unassigned
              Reporter:
              joncrooke Jonathan Crooke
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: