Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22750

Polling no longer triggers builds (regression 1.560)

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: core
    • Labels:
    • Environment:
      Linux localhost.localdomain 2.6.32-431.1.2.el6.x86_64 #1 SMP Thu Dec 12 13:59:19 CST 2013 x86_64 x86_64 x86_64 GNU/Linux
    • Similar Issues:

      Description

      As of version 1.560, polling my private mercurial repository hosted by BitBucket no longer works. Before version 1.560 this worked as expected. Other than Jenkins itself, there were no other changes to the system. The poll configuration looks like:

      H/5 * * * *

      The "poll log" says the following:

      Started on Apr 24, 2014 8:08:05 AM
      We need to schedule a new build to get a workspace, but deferring 1,149ms in the hope that one will become available soon (all_suitable_nodes_are_offline)
      Done. Took 1 ms
      No changes
      

      The build does have a valid workspace. Doing a manual build to "get a workspace" does work but does not resolve the polling issue.

      This is a single Jenkins instance without any slaves.

      I'd be happy to provide any other logs, information, or tests required to resolve this issue.

        Attachments

          Issue Links

            Activity

            kurt Kurt Nuke added a comment -

            I am seeing this issue on an upgrade to Jenkins ver. 1.651.2 – For us, this is still a critical bug.

            danielbeck Daniel Beck added a comment -

            Kurt Nuke: Whatever you're seeing is almost guaranteed a different issue.

            kurt Kurt Nuke added a comment -

            Daniel Beck Sadly not, exact same error message and SCM polling is not working on just a few builds, randomly. This seemed to occur after a node died due to hw issues. Still having the same issue.

            kurt Kurt Nuke added a comment -

            Daniel Beck Should I make a new issue for this – I can provide any information needed, though the issues are very similar.

            danielbeck Daniel Beck added a comment -

            Kurt Nuke Would be best, I think.


              People

              • Assignee:
                arov Alex Rovner
                Reporter:
                jdufresne Jon Dufresne
              • Votes:
                43 Vote for this issue
                Watchers:
                75 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: