Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22820

Changes are not commited when using a recent git client

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      jenkins 1.559, scm-sync-plugin 0.7.4, git plugin 2.2.1
      git 1.9.2
    • Similar Issues:

      Description

      After an upgrade from Ubuntu 12.04 to Ubuntu 14.04, I realized changes were just piling up in `scm-sync-configuration/checkoutConfiguration`. They do show up as staged but nothing is ever commited nor pushed.

      It seems to be related to the version of the git client as downgrading to Ubuntu 13.10's git binaries (1.8.1.2) fixes the problem.

      Trying to recompile the plugin against maven-scm-provider-gitexe:1.9 or maven-scm-provider-jgit:1.9 did not help.

      Logs don't show any error:

      Apr 30, 2014 4:02:53 PM FINE hudson.plugins.scm_sync_configuration.SCMManipulator
      Checking in SCM files ... 
      Apr 30, 2014 4:02:53 PM FINE hudson.plugins.scm_sync_configuration.SCMManipulator
      Checked in SCM files !
      Apr 30, 2014 4:02:53 PM FINEST hudson.plugins.scm_sync_configuration.ScmSyncConfigurationBusiness
      Commit Commit hudson.plugins.scm_sync_configuration.model.Commit@11812cee : 
        Author : null
        Comment : Jenkins configuration files updated
        Changeset : 
          A hudson.scm.SubversionSCM.xml
          A hudson.tasks.Shell.xml
          A scm-sync-configuration.xml
          A hudson.plugins.ansicolor.AnsiColorBuildWrapper.xml
          A hudson.plugins.git.GitTool.xml
          A hudson.scm.CVSSCM.xml
          A hudson.tasks.Mailer.xml
          A config.xml
          A hudson.tasks.Ant.xml
          A hudson.tasks.Maven.xml
          A hudson.plugins.git.GitSCM.xml
          A hudson.plugins.timestamper.TimestamperConfig.xml
          A hudson.triggers.SCMTrigger.xml
          A hudson.plugins.emailext.ExtendedEmailPublisher.xml
          A hudson.maven.MavenModuleSet.xml
      
       pushed to SCM !
      

        Attachments

          Activity

          colonelcoder David Cullen added a comment -

          I have installed the 0.0.8 version of the scm-sync-configuration plugin and it still does not work with git 1.9.1 on Ubuntu 14.04.
          The 0.0.8 version of the plugin partially works with git 1.8.3.2; however, the commit message dialog is not displayed.
          Is there anything I can do to help resolve these problems?

          rogerhu rogerhu added a comment -

          The commit message dialog not being displayed is a different issue and a regression from a previous change.

          What other symptoms are you seeing?

          You can debug this too by using IntelliJ Community Edition and importing the project too...click right-click on the hpi:run and you can startup your own instance of Jenkins (bit.ly/1t9vKDd)

          colonelcoder David Cullen added a comment -

          > What other symptoms are you seeing?

          When I install git 1.9.1 the checkoutConfiguration directory is created but the .git repository is not cloned from the remote.

          I am unable to build the plugin. If I change the parent version to 1.509 so that the plugin will build with Java 7, the tests fail:

            <parent>
              <groupId>org.jenkins-ci.plugins</groupId>
              <artifactId>plugin</artifactId>
              <version>1.509</version>
              <relativePath>../pom.xml</relativePath>
            </parent>
          

          Are you building against Java 6?

          rogerhu rogerhu added a comment -

          I just rechecked with this latest plugin and it works fine on Ubuntu 14.04 and Git 1.9.1. Furthermore, Git 2.1.0 also works fine.

          I would go to System Log -> add a Log recorder for "hudson.plugins.scm_sync_configuration". It should be more obvious what the issue is on your system.

          Yes, Java 6. Also you can skip setting the parent version (leave it) since there are dependencies going from Hudson to Jenkins.

          colonelcoder David Cullen added a comment -

          The problem is that the scm-sync-plugin no longer supports git+ssh URIs:

              ssh: Could not resolve hostname git%2bssh: Name or service not known
          

          After I removed the "git+" from the URI, the plugin worked with git 1.9.1.

          I still do not get commit message dialogs. Will I be able to debug that using the setup in your blog post?

          Also, what JDK should I install? I think that Java 7 was installed because I used the PPA to install Jenkins and it pulled in the default JRE during the install.


            People

            • Assignee:
              fcamblor Frédéric Camblor
              Reporter:
              bjaglin Brice Jaglin
            • Votes:
              7 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: