Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: dry-plugin
    • Labels:
      None
    • Environment:
      jenkins: 1.559 to 1.563
      dry: 2.40
      master: windows 2003
    • Similar Issues:

      Description

      I have simian to scan my code, and the result file is about 2.5M. When i click the hyperlinks or icon to view the detail,jenkins responds so slowly, that it always takes me a few minutes to wait for another operation untill i restart the master.

        Attachments

          Activity

          bindwood shans zoe added a comment -

          Have you viewed the threadDump.txt? I use only dry in #76。 Since I have uninstalled dry plugin, I install it again,and use both violations plugin and dry plugin in #99 to reproduce what happen.

          The error in comment is raised when I use only voilations plugin and when my xml file is larger then 5M.

          drulli Ulli Hafner added a comment -

          Sorry, I did not yet look into the threadDump: I just responded to your comment above with the violations stack trace. So this is something different? Please do not mix issues and plugins, this makes it hard to follow...

          drulli Ulli Hafner added a comment -

          How big is the dry-warnings.xml file of these two builds? (located in your build folder)

          bindwood shans zoe added a comment -

          65358KB in #76, 53692KB in #99

          drulli Ulli Hafner added a comment -

          I don't see what I can do here. Maybe you should increase the lines threshold to get smaller result files.


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              bindwood shans zoe
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: