Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23160

Newly added module locations' / additional credentials' "Add" credential button does not work

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Server: Jenkins 1.561, Credentials Plugin 1.9.4 behind Apache on CentOS
      Client: Firefox 29.0.1, OS X 10.9.2
    • Similar Issues:

      Description

      Steps to reproduce

      1. Create a new job.
      2. Select Subversion SCM
      3. Click 'Add' next to credential selection of first module location. Notice that popup opens.
      4. Close popup.
      5. Click 'Add module...' or 'Add additional credentials...'
      6. Click 'Add' next to credential selection of newly added form controls

      Expected result
      Popup opens

      Actual result
      Nothing happens

      Notes
      even color-on-hover and pressed state while clicking don't work for these buttons.

      No messages logged in console.

        Attachments

          Issue Links

            Activity

            stephenconnolly Stephen Connolly added a comment -

            To clarify the issue here is that the buttons do not work on any modules that are added until after a round-trip with the server (i.e. save & reload config screen)

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            src/main/resources/lib/credentials/select.jelly
            src/main/resources/lib/credentials/select/select.css
            src/main/resources/lib/credentials/select/select.js
            http://jenkins-ci.org/commit/credentials-plugin/7c263cbb86276cf9a7ff67c43d6532776efac5aa
            Log:
            [FIXED JENKINS-23160] Newly added module locations' / additional credentials' "Add" credential button does not work

            • Also changed the width of the drop-down to be auto so that the add button is more clearly associated
            • Also fixed select box alignment with add button

            Note:

            • Root cause was f:repeatable was neither generating a new id nor re-executing the in-line script, this fixes both in one go by using Behaviour to apply the rule thus removing the need for the id on the button
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            pom.xml
            src/main/java/com/cloudbees/jenkins/plugins/sshagent/SSHAgentBuildWrapper.java
            src/main/resources/com/cloudbees/jenkins/plugins/sshagent/Messages.properties
            src/main/resources/com/cloudbees/jenkins/plugins/sshagent/SSHAgentBuildWrapper/CredentialHolder/config.jelly
            src/main/resources/com/cloudbees/jenkins/plugins/sshagent/SSHAgentBuildWrapper/config.jelly
            http://jenkins-ci.org/commit/ssh-agent-plugin/3bc16fd5ecad520345f0c6d7095aed4098c2fd61
            Log:
            Add support for multiple credentials (subject to JENKINS-23160 until we upgrade the credentials plugin dependency)


              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                danielbeck Daniel Beck
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: