Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23442

Jenkins 1.568 can not start when monitoring plugin is installed

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: monitoring-plugin
    • Labels:
      None
    • Environment:
    • Similar Issues:

      Description

      After upgrading to Jenkins version 1.568 it can not start.
      The following is the last entry in the log file no matter how long I wait.

      Exception in thread "Thread-3" java.lang.ClassCircularityError: java/util/logging/LogRecord
      at net.bull.javamelody.LoggingHandler.publish(LoggingHandler.java:109)
      at java.util.logging.Logger.log(Logger.java:616)
      at java.util.logging.Logger.doLog(Logger.java:641)
      at java.util.logging.Logger.log(Logger.java:730)
      at winstone.Logger.logInternal(Logger.java:157)
      at winstone.Logger.log(Logger.java:165)

      Stopping Jenkins again and deleting file ./plugins/monitoring.jpi and folder ./plugins/monitoring/ allows me to get Jenkins running again, so that can work as a workaround

        Attachments

          Issue Links

            Activity

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: evernat
            Path:
            src/main/java/org/jvnet/hudson/plugins/monitoring/PluginImpl.java
            http://jenkins-ci.org/commit/monitoring-plugin/0ad60da0038048ca69672022e54434cb3c5c87a3
            Log:
            try to fix JENKINS-23442 (ClassCircularityError: java/util/logging/LogRecord)

            jglick Jesse Glick added a comment -

            So now resolved/fixed?

            evernat evernat added a comment -

            The code changed in the plugin is a tentative fix without having reproduced the issue myself.
            So, I would like a confirmation from a user before saying that it is fixed.

            To everyone:
            You can test the fix by downloading a nightly build here:
            https://javamelody.ci.cloudbees.com/job/jenkins%20plugin/ws/target/monitoring.hpi

            anigif Anders Kielsholm added a comment - - edited

            It seems to be working for us, we had the same problem before. And now, after installing the snapshot it doesn't hang anymore (and we can acess /monitoring)

            evernat evernat added a comment -

            Thanks Anders for the confirmation.


              People

              • Assignee:
                Unassigned
                Reporter:
                jbrejner Jens Brejner
              • Votes:
                7 Vote for this issue
                Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: