Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23505

Wrong package for OS X version detected

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Testing on three different OS X machines (including the master), I see this in the build console output:

      Unpacking Go from http://golang.org/dl/go1.3.darwin-amd64-osx10.6.tar.gz
      

      However, these machines all have 10.9.3, so should install the "osx10.8" package.

      System properties on the tested slaves are identical:

      os.arch     x86_64
      os.name	    Mac OS X
      os.version  10.9.3
      

        Attachments

          Activity

          Hide
          orrc Christopher Orr added a comment -

          Looking at the JSON, Go 1.3 lists the 10.6 package before the one for 10.8.
          However, Go 1.2.1 (on the old download site) lists 10.8 before 10.6.

          Looking at the code, we naively return the first package for which our os.version is higher...

          Show
          orrc Christopher Orr added a comment - Looking at the JSON, Go 1.3 lists the 10.6 package before the one for 10.8. However, Go 1.2.1 (on the old download site) lists 10.8 before 10.6. Looking at the code, we naively return the first package for which our os.version is higher...
          Hide
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Christopher Orr
          Path:
          src/main/java/org/jenkinsci/plugins/golang/GolangInstaller.java
          src/test/java/org/jenkinsci/plugins/golang/GolangInstallerTest.java
          http://jenkins-ci.org/commit/golang-plugin/2bc19be35f470a49d772f54f909fd29b97a9090f
          Log:
          [FIXED JENKINS-23505] Ensure correct package for OS X version is installed.

          Show
          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Christopher Orr Path: src/main/java/org/jenkinsci/plugins/golang/GolangInstaller.java src/test/java/org/jenkinsci/plugins/golang/GolangInstallerTest.java http://jenkins-ci.org/commit/golang-plugin/2bc19be35f470a49d772f54f909fd29b97a9090f Log: [FIXED JENKINS-23505] Ensure correct package for OS X version is installed.
          Hide
          orrc Christopher Orr added a comment -

          Version 1.1 of the plugin has been released, which fixes this issue.

          Show
          orrc Christopher Orr added a comment - Version 1.1 of the plugin has been released, which fixes this issue.

            People

            • Assignee:
              orrc Christopher Orr
              Reporter:
              orrc Christopher Orr
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: