Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23596

jenkins plugin vanished after update

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate
    • Component/s: core
    • Labels:
    • Environment:
      CentOS 6.5 64 bit
    • Similar Issues:

      Description

      Jenkins version 1.568,after update to 1.569,issue still remains.
      It's a little bit complicated to reproduce the bug. The Jenkins server we use is behind the firewall with limited access to the internet.So one day our ops decide to update the plugin we use on a whim,when he re-login to check the status later,all plugin just vanished.Not just disappear from the plugin manager list,the plugin files don't exist on the system too.

      And here's some log:

      Jun 26, 2014 4:58:17 PM jenkins.InitReactorRunner$1 onTaskFailed
      SEVERE: Failed Inspecting plugin /data/jenkins/plugins/cvs.jpi
      java.io.IOException: Failed to expand /data/jenkins/plugins/cvs.jpi
      at hudson.ClassicPluginStrategy.explode(ClassicPluginStrategy.java:484)
      at hudson.ClassicPluginStrategy.createPluginWrapper(ClassicPluginStrategy.java:150)
      at hudson.PluginManager$1$3$1.run(PluginManager.java:240)
      at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169)
      at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282)
      at jenkins.model.Jenkins$7.runTask(Jenkins.java:885)
      at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210)
      at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: Error while expanding /data/jenkins/plugins/cvs.jpi
      java.util.zip.ZipException: archive is not a ZIP archive
      at org.apache.tools.ant.taskdefs.Expand.expandFile(Expand.java:192)
      at org.apache.tools.ant.taskdefs.Expand.execute(Expand.java:132)
      at hudson.ClassicPluginStrategy.unzipExceptClasses(ClassicPluginStrategy.java:556)
      at hudson.ClassicPluginStrategy.explode(ClassicPluginStrategy.java:481)
      ... 10 more
      Caused by: java.util.zip.ZipException: archive is not a ZIP archive
      at org.apache.tools.zip.ZipFile.positionAtCentralDirectory(ZipFile.java:481)
      at org.apache.tools.zip.ZipFile.populateFromCentralDirectory(ZipFile.java:320)
      at org.apache.tools.zip.ZipFile.<init>(ZipFile.java:186)
      at org.apache.tools.ant.taskdefs.Expand.expandFile(Expand.java:170)
      ... 13 more

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-14616.


              People

              • Assignee:
                Unassigned
                Reporter:
                ihacku visual zhang
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: