Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: github-plugin
    • Labels:
      None
    • Environment:
      Jenkins version 1.570
    • Similar Issues:

      Description

      Getting this error when the github webhook is invoked:

      WARNING: Error while serving http://my-ci-server/github-webhook/
      java.lang.reflect.InvocationTargetException
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at java.lang.Thread.run(Thread.java:744)
      [...]
      Caused by: java.lang.IllegalArgumentException: Github Webhook event of type null is not supported. Only push events are current supported
              at com.cloudbees.jenkins.GitHubWebHook.doIndex(GitHubWebHook.java:160)
              ... 71 more
      

        Attachments

          Issue Links

            Activity

            real_ate Chris Manson added a comment -

            Thanks @Gennady, I never even knew you could roll back a plugin version! I also got a little snagged by not restarting Jenkins after the downgrade. I'm all back up and running again though so thanks to both of you

            stevejansen Steve Jansen added a comment -

            Good news, it looks like the GitHub service for the "Jenkins (GitHub plugin)" was just updated.

            The change @ https://github.com/github/github-services/blame/master/lib/services/jenkins_github.rb#L16 looks like it will fix this problem for the plugin v1.9.

            I'm not sure if this change is live on GitHub.com, or if you will need to recreate the Jenkins service on the "Webhooks & Services" setting panel @ https://github.com/:org-or-user/:repo/settings/hooks

            nukulb Nukul Bhasin added a comment - - edited

            I explained here what exactly happened here.

            https://github.com/github/github-services/commit/19a3c876e483e2470f21f756ac9ee0499b5c4322#diff-96256a1827d9dfd0cd6a1f068b18831dR12

            I will put up a new fix for the plugin, for now the change in github services will suffice to get folks rolling.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nukul Bhasin
            Path:
            src/main/java/com/cloudbees/jenkins/GitHubWebHook.java
            http://jenkins-ci.org/commit/github-plugin/4cfd5efdc6665e768a2c114c3ccc3cd85d78fd33
            Log:
            [FIXED JENKINS-23661]

            Github webhook specifies a "X-Github-Event" header but github services do not.
            This adds back the support github services that don't specify a header to just
            fallback on the old code.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nukul Bhasin
            Path:
            src/main/java/com/cloudbees/jenkins/GitHubWebHook.java
            http://jenkins-ci.org/commit/github-plugin/18e9de49c44ae56045945616e488f3cb9966f3c9
            Log:
            Merge pull request #43 from hubba/master

            [FIXED JENKINS-23661]

            Compare: https://github.com/jenkinsci/github-plugin/compare/bf6ed268d626...18e9de49c44a


              People

              • Assignee:
                Unassigned
                Reporter:
                x110dc Daniel Craigmile
              • Votes:
                6 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: