Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23749

Incomplete view configuration breaks all Jenkins views

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: build-pipeline-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.571
      Build Pipeline 1.4.3
    • Similar Issues:

      Description

      Steps to reproduce:

      1. Go to /newView
      2. Enter a name for the view
      3. Select type 'Build Pipeline View
      4. Press OK
      5. Do NOT save, go back to home page (or any other view)

      Expected results

      No problems accessing the home page or any other view page, or even the new Build Pipeline view, really.

      Actual results

      Stack trace preventing the view from showing up. Excerpt:

      Caused by: java.lang.NumberFormatException: null
      	at java.lang.Integer.parseInt(Integer.java:454)
      	at java.lang.Integer.valueOf(Integer.java:582)
      	at au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView.getBuildPipelineForm(BuildPipelineView.java:400)
      	at au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView.getItems(BuildPipelineView.java:866)
      	at au.com.centrumsystems.hudson.plugin.buildpipeline.BuildPipelineView.hasPermission(BuildPipelineView.java:932)
      	at hudson.model.ViewGroupMixIn.getViews(ViewGroupMixIn.java:115)
      	at jenkins.model.Jenkins.getViews(Jenkins.java:1444)

      Notes

      When aborting configuration of the new view, users need to manually navigate to /view/ViewName/configure to be able to delete it.

      This likely also affects instances with multiple users: While one user sets up initial configuration of the Build Pipeline view, Jenkins breaks for all others.

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Duplicates JENKINS-23363.

            schristou Steven Christou added a comment -

            Not a duplicate of JENKINS-23363.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: christ66
            Path:
            src/main/java/au/com/centrumsystems/hudson/plugin/buildpipeline/BuildPipelineView.java
            http://jenkins-ci.org/commit/build-pipeline-plugin/880ba84553e1e6a58c284a8c8a705495ed5911b0
            Log:
            [FIXED JENKINS-23749] If a pipeline does not have any builds it will throw a NPE.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Nicolas De loof
            Path:
            src/main/java/au/com/centrumsystems/hudson/plugin/buildpipeline/BuildPipelineView.java
            http://jenkins-ci.org/commit/build-pipeline-plugin/59780cbc3767b1993e59184fcec21262a6f8fa51
            Log:
            Merge pull request #53 from christ66/JENKINS-23749

            [FIXED Jenkins-23749] NPE when view contains no builds.

            Compare: https://github.com/jenkinsci/build-pipeline-plugin/compare/b6a01ad04b22...59780cbc3767


              People

              • Assignee:
                schristou Steven Christou
                Reporter:
                danielbeck Daniel Beck
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: