Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23969

When restarting server builds nodes do not remain online

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Incomplete
    • Component/s: core
    • Labels:
      None
    • Environment:
      Ubuntu
    • Similar Issues:

      Description

      When restarting the server the build nodes constantly switch between online and offline. Log file contains the following

      Jul 24, 2014 8:08:24 AM WARNING hudson.node_monitors.AbstractAsyncNodeMonitorDescriptor monitor

      Failed to monitor auto-tst-dev-w1 for Free Disk Space
      java.nio.channels.ClosedChannelException
      at sun.nio.ch.SocketChannelImpl.ensureWriteOpen(SocketChannelImpl.java:249)
      at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:440)
      at hudson.remoting.SocketChannelStream$2.write(SocketChannelStream.java:62)
      at java.nio.channels.Channels.writeFullyImpl(Channels.java:78)
      at java.nio.channels.Channels.writeFully(Channels.java:101)
      at java.nio.channels.Channels.access$000(Channels.java:61)
      at java.nio.channels.Channels$1.write(Channels.java:174)
      at java.io.ObjectOutputStream$BlockDataOutputStream.drain(ObjectOutputStream.java:1857)
      at java.io.ObjectOutputStream$BlockDataOutputStream.setBlockDataMode(ObjectOutputStream.java:1766)
      at java.io.ObjectOutputStream.writeFatalException(ObjectOutputStream.java:1560)
      at java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:349)
      at hudson.remoting.Command.writeTo(Command.java:83)
      at hudson.remoting.ClassicCommandTransport.write(ClassicCommandTransport.java:51)
      at hudson.remoting.Channel.send(Channel.java:545)
      at hudson.remoting.Request.callAsync(Request.java:208)
      at hudson.remoting.Channel.callAsync(Channel.java:766)
      at hudson.node_monitors.AbstractAsyncNodeMonitorDescriptor.monitor(AbstractAsyncNodeMonitorDescriptor.java:76)
      at hudson.node_monitors.AbstractNodeMonitorDescriptor$Record.run(AbstractNodeMonitorDescriptor.java:280)

      Jul 24, 2014 8:08:24 AM WARNING hudson.node_monitors.AbstractAsyncNodeMonitorDescriptor monitor

      Failed to monitor auto-tst-prd-w1 for Free Disk Space
      hudson.remoting.ChannelClosedException: channel is already closed
      at hudson.remoting.Channel.send(Channel.java:541)
      at hudson.remoting.Request.callAsync(Request.java:208)
      at hudson.remoting.Channel.callAsync(Channel.java:766)
      at hudson.node_monitors.AbstractAsyncNodeMonitorDescriptor.monitor(AbstractAsyncNodeMonitorDescriptor.java:76)
      at hudson.node_monitors.AbstractNodeMonitorDescriptor$Record.run(AbstractNodeMonitorDescriptor.java:280)
      Caused by: java.nio.channels.AsynchronousCloseException
      at java.nio.channels.spi.AbstractInterruptibleChannel.end(AbstractInterruptibleChannel.java:205)
      at sun.nio.ch.SocketChannelImpl.read(SocketChannelImpl.java:386)
      at hudson.remoting.SocketChannelStream$1.read(SocketChannelStream.java:33)
      at sun.nio.ch.ChannelInputStream.read(ChannelInputStream.java:65)
      at sun.nio.ch.ChannelInputStream.read(ChannelInputStream.java:109)
      at sun.nio.ch.ChannelInputStream.read(ChannelInputStream.java:103)
      at java.io.InputStream.read(InputStream.java:101)
      at sun.nio.ch.ChannelInputStream.read(ChannelInputStream.java:81)
      at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:82)
      at java.io.ObjectInputStream$PeekInputStream.peek(ObjectInputStream.java:2291)
      at java.io.ObjectInputStream$BlockDataInputStream.peek(ObjectInputStream.java:2584)
      at java.io.ObjectInputStream$BlockDataInputStream.peekByte(ObjectInputStream.java:2594)
      at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1316)
      at java.io.ObjectInputStream.readObject(ObjectInputStream.java:370)
      at hudson.remoting.Command.readFrom(Command.java:92)
      at hudson.remoting.ClassicCommandTransport.read(ClassicCommandTransport.java:70)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          Can you provide more details of the configured environment and how it is configured? In particular, the types of information described in what to report in the description of an issue report will be more likely to allow the Jenkins developers to more rapidly understand and resolve the problem.

          danielbeck Daniel Beck added a comment -

          No response to comment asking for additional information in 2 weeks, so resolving as Incomplete.


            People

            • Assignee:
              Unassigned
              Reporter:
              rslade Richard Slade
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: