Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24129

Unexpected error in launching a slave. This is probably a bug in Jenkins.

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Component/s: selenium-plugin
    • Labels:
      None
    • Environment:
      Ubuntu 14.04
      Jenkins 1.574
    • Similar Issues:

      Description

      Slave machine is showing offline and no jobs complete.

      Able to manually ssh in to the slave machine and run the same scripts

        Attachments

          Activity

          Hide
          danielbeck Daniel Beck added a comment -

          Given the NPE location it seems safe to assume an issue with the Selenium plugin.

          Show
          danielbeck Daniel Beck added a comment - Given the NPE location it seems safe to assume an issue with the Selenium plugin.
          Hide
          zonkey Neal Storey added a comment -

          Disabling the Selenium Plugin did in fact bring the node back online. I attempted and uninstall but for whatever reason, it didn't uninstall. Re-enabling it caused the node to go offline again.

          I'm going to attempt a downgrade from 2.4.1 to 2.3 to see if I can at least get this operational again.

          Show
          zonkey Neal Storey added a comment - Disabling the Selenium Plugin did in fact bring the node back online. I attempted and uninstall but for whatever reason, it didn't uninstall. Re-enabling it caused the node to go offline again. I'm going to attempt a downgrade from 2.4.1 to 2.3 to see if I can at least get this operational again.
          Hide
          zonkey Neal Storey added a comment -

          downgrading to 2.3 seems to make it operational again. So strange why this suddenly failed to work. And I mean, I've had 2.4.1 installed since mid April/May and it experienced no issues until Tuesday (yesterday). Anyway, thanks for pointing that out Daniel.

          Show
          zonkey Neal Storey added a comment - downgrading to 2.3 seems to make it operational again. So strange why this suddenly failed to work. And I mean, I've had 2.4.1 installed since mid April/May and it experienced no issues until Tuesday (yesterday). Anyway, thanks for pointing that out Daniel.
          Hide
          zonkey Neal Storey added a comment -

          I lied. It downgraded but wasn't enabled. Once enabled it went offline again. Problem persists regardless of Selenium Plugin version. Makes me think there is another underlying issue.

          Show
          zonkey Neal Storey added a comment - I lied. It downgraded but wasn't enabled. Once enabled it went offline again. Problem persists regardless of Selenium Plugin version. Makes me think there is another underlying issue.
          Hide
          danielbeck Daniel Beck added a comment -

          Check your "web driver browser" configuration, there seem to be no such browsers to be configured.

          Still, robustness this is not.

          Show
          danielbeck Daniel Beck added a comment - Check your "web driver browser" configuration, there seem to be no such browsers to be configured. Still, robustness this is not.
          Hide
          mmeiller Mark Meiller added a comment -

          I just encountered the same problem today after upgrading from 1.584 to 1.588 this was the one and only change i made. I ended up downgrading twice to 1.586 and the error went away. Which is unfortunate because 1.588 has a bug fix i was interested in.

          Show
          mmeiller Mark Meiller added a comment - I just encountered the same problem today after upgrading from 1.584 to 1.588 this was the one and only change i made. I ended up downgrading twice to 1.586 and the error went away. Which is unfortunate because 1.588 has a bug fix i was interested in.

            People

            • Assignee:
              darkrift Richard Lavoie
              Reporter:
              zonkey Neal Storey
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: