Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24149

LogConfigurationException due to conflicting commons-logging versions

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: swarm-plugin
    • Labels:
      None
    • Environment:
      LTS 1.565.1
    • Similar Issues:

      Description

      We run a Maven type job using Jenkins version 1.565.1.
      When building on master, the job builds fine.
      When using a swarm client, the job fails with the following error shown in the console log:

      ...
      	at org.kohsuke.stapler.Stapler.<clinit>(Stapler.java:1062)
      	... 51 more
      Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.)
      	at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:397)
      	at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:529)
      	... 56 more
      Caused by: org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.
      	at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:385)
      	... 57 more
      channel stopped
      

        Attachments

          Activity

            People

            • Assignee:
              mindjiver Peter Jönsson
              Reporter:
              rkok Rene Kok
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: