Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24481

Could not deleting files/folder in workspace

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      We are getting Error in deleting files/folder in workspace.
      Please see below logs for more detail

      _________________________________________________________________________
      _________________________________________________________________________

      18:17:46 Allure Report Generation: attach report link to build and project
      18:17:48 Allure Report Generation: Can't delete directory [D:\Jenkins\Core\Artifacts\workspace\Scepter-Hotel-Search-Travelguru_1_0\allure3996563737139319681.tmp]
      18:17:48 java.io.IOException: remote file operation failed: D:\Jenkins\Core\Artifacts\workspace\Scepter-Hotel-Search-Travelguru_1_0\allure3996563737139319681.tmp at hudson.remoting.Channel@f61a9a:Cylon-Slave
      18:17:48 at hudson.FilePath.act(FilePath.java:913)
      18:17:48 at hudson.FilePath.act(FilePath.java:895)
      18:17:48 at hudson.FilePath.deleteContents(FilePath.java:1104)
      18:17:48 at ru.yandex.qatools.allure.jenkins.AllureReportPublisher.deleteRecursive(AllureReportPublisher.java:215)
      18:17:48 at ru.yandex.qatools.allure.jenkins.AllureReportPublisher.perform(AllureReportPublisher.java:137)
      18:17:48 at org.jenkins_ci.plugins.run_condition.BuildStepRunner$2.run(BuildStepRunner.java:110)
      18:17:48 at org.jenkins_ci.plugins.run_condition.BuildStepRunner$Fail.conditionalRun(BuildStepRunner.java:154)
      18:17:48 at org.jenkins_ci.plugins.run_condition.BuildStepRunner.perform(BuildStepRunner.java:105)
      18:17:48 at org.jenkins_ci.plugins.flexible_publish.ConditionalPublisher.perform(ConditionalPublisher.java:134)
      18:17:48 at org.jenkins_ci.plugins.flexible_publish.FlexiblePublisher.perform(FlexiblePublisher.java:111)
      18:17:48 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      18:17:48 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
      18:17:48 at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:734)
      18:17:48 at hudson.model.Build$BuildExecution.post2(Build.java:183)
      18:17:48 at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:683)
      18:17:48 at hudson.model.Run.execute(Run.java:1765)
      18:17:48 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      18:17:48 at hudson.model.ResourceController.execute(ResourceController.java:89)
      18:17:48 at hudson.model.Executor.run(Executor.java:240)
      18:17:48 Caused by: java.nio.file.FileSystemException: D:\Jenkins\Core\Artifacts\workspace\Scepter-Hotel-Search-Travelguru_1_0\allure3996563737139319681.tmp\repositories\com\fasterxml\jackson\core\jackson-annotations\2.3.0\jackson-annotations-2.3.0.jar: The process cannot access the file because it is being used by another process.
      18:17:48
      18:17:48 at sun.nio.fs.WindowsException.translateToIOException(Unknown Source)
      18:17:48 at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
      18:17:48 at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
      18:17:48 at sun.nio.fs.WindowsFileSystemProvider.implDelete(Unknown Source)
      18:17:48 at sun.nio.fs.AbstractFileSystemProvider.delete(Unknown Source)
      18:17:48 at java.nio.file.Files.delete(Unknown Source)
      18:17:48 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      18:17:48 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      18:17:48 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      18:17:48 at java.lang.reflect.Method.invoke(Unknown Source)
      18:17:48 at hudson.Util.deleteFile(Util.java:247)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:310)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:301)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:301)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:301)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:301)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:301)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:301)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.Util.deleteRecursive(Util.java:301)
      18:17:48 at hudson.Util.deleteContentsRecursive(Util.java:212)
      18:17:48 at hudson.FilePath$13.invoke(FilePath.java:1107)
      18:17:48 at hudson.FilePath$13.invoke(FilePath.java:1104)
      18:17:48 at hudson.FilePath$FileCallableWrapper.call(FilePath.java:2483)
      18:17:48 at hudson.remoting.UserRequest.perform(UserRequest.java:118)
      18:17:48 at hudson.remoting.UserRequest.perform(UserRequest.java:48)
      18:17:48 at hudson.remoting.Request$2.run(Request.java:328)
      18:17:48 at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:72)
      18:17:48 at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      18:17:48 at java.util.concurrent.FutureTask.run(Unknown Source)
      18:17:48 at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
      18:17:48 at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      18:17:48 at hudson.remoting.Engine$1$1.run(Engine.java:63)
      18:17:48 at java.lang.Thread.run(Unknown Source)
      18:17:48 Allure Report Generation: completed

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Unless allure forgets to close some files, this is a duplicate of JENKINS-15331 caused by Windows file locking.

            Make sure this happens also with antivirus, search indexer, etc. disabled.

            mavlyutov Marat Mavlyutov added a comment -

            duplicates JENKINS-15331

            arpitgold Arpit Nagar added a comment - - edited

            It has been still not fixed.
            Allure tries to delete file but it says, some files are still in use.
            It is not because of Antivirus, firewall or such.
            Can we introduce any type of mechanism to unlock the folder before deleting files.

            danielbeck Daniel Beck added a comment -

            Arpit Nagar: Nobody claimed it is. It's resolved as duplicate after review by the plugin maintainer, since there's no point in keeping multiple copies of the same issue around.


              People

              • Assignee:
                mavlyutov Marat Mavlyutov
                Reporter:
                arpitgold Arpit Nagar
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: