Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-24772

git polling performs deprecated call to Run.getEnvironment at hudson.plugins.git.GitSCM.getParamExpandedRepos(GitSCM.java:355)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.580, git plugin 2.2.5
    • Similar Issues:

      Description

      My jenkins.log grew by about 1 gigabyte overnight by repeating

      Sep 19, 2014 9:20:00 AM hudson.model.Run getEnvironment
      WARNING: deprecated call to Run.getEnvironment
      at hudson.plugins.git.GitSCM.getParamExpandedRepos(GitSCM.java:355)

      14 times every minute. (Yes, I have a lot of jobs that poll inefficiently. I'll fix that.)

      It would be nice if the git plugin were fixed not to do that any more.

      (Incidentally, it would be even nicer if deprecation warnings were displayed at most once per call site, like in Python.)

        Attachments

          Issue Links

            Activity

            Hide
            markewaite Mark Waite added a comment -

            That warning was resolved by Jesse Glick in a git plugin 2.3 beta. You could consider using the 2.3 beta plugin as well, if that warning is a serious concern for you.

            Jesse Glick, was there a specific reason that change was not cherry picked to the 2.2.x (stable) branch?

            Show
            markewaite Mark Waite added a comment - That warning was resolved by Jesse Glick in a git plugin 2.3 beta. You could consider using the 2.3 beta plugin as well, if that warning is a serious concern for you. Jesse Glick , was there a specific reason that change was not cherry picked to the 2.2.x (stable) branch?
            Hide
            markewaite Mark Waite added a comment -

            I'm attempting a cherry pick of the change from the master branch to 2.2.x branch. If it passes the tests, it can be included in the next git plugin 2.2.x release.

            Show
            markewaite Mark Waite added a comment - I'm attempting a cherry pick of the change from the master branch to 2.2.x branch. If it passes the tests, it can be included in the next git plugin 2.2.x release.
            Hide
            markewaite Mark Waite added a comment -

            Fixed in git plugin 2.2.6, released 20 Sep 2014

            Show
            markewaite Mark Waite added a comment - Fixed in git plugin 2.2.6, released 20 Sep 2014

              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                mgedmin Marius Gedminas
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: