Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2508

JIRA plugin not updating JIRA when perforce plugin used

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: jira-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      HUDSON is not updating the relevant JIRA issues with back pointers to builds
      when the perforce plugin is configured for SCM. From the plugin guidelines
      (http://hudson.gotdns.com/wiki/display/JENKINS/JIRA+Plugin) it appears that the
      JIRA plugin is performing a match on the change text to relate this to a
      specific issue in JIRA, but when Perforce is used for SCM the change detail now
      shows changelist numbers instead and the detail required to match the issue in
      JIRA is only displayed when hyperlinking from the changelist number. (I think it
      needs to use the Perforce Job name to match to the issue key in JIRA)

        Attachments

          Activity

          slamdunc slamdunc added a comment -

          Hi...is there any movement on this Show Stopper error? It seems that no-one owns
          this component anymore!!

          smadden Sandra Madden added a comment -

          attached patch that catches exception that is thrown because the current Perforce plugin doesn't implement getAffectedFiles (hudson.scm.ChangeLogSet.Entry.getAffectedFiles()).

          Catching the exception allows the JIRA plugin to finish creating the comment, it just lacks the list of files.

          A full fix (adding the file list) depends on implementing JENKINS-8050 in the Perforce plugin

          smadden Sandra Madden added a comment -

          Hi Olivier,

          I wasn't sure if you get a notification even if the issue is unassigned. Since you are listed as the current owner of the JIRA plugin, could you please take a look at the patch that I attached to this issue? It's just adding an exception handling so that the comment in jira is still created (see bug description for details).

          Thanks,
          Sandra

          smadden Sandra Madden added a comment -

          as suggested by rpetti, added fallback to use getAffectedPaths() if getAffectedFiles() is not implemented by SCM plugin.

          olamy Olivier Lamy added a comment -

          patch pushed


            People

            • Assignee:
              olamy Olivier Lamy
              Reporter:
              slamdunc slamdunc
            • Votes:
              2 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: