Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25375

Testlink plugin throws an NoSuchMethodError

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins 1.587
      Testlink Plugin 3.10
      JUnit Plugin 1.2-beta-3
    • Similar Issues:

      Description

      In the "Result Seeking Strategy" step an NoSuchMethodError is raised.

      FATAL: hudson.tasks.junit.JUnitParser.parse(Ljava/lang/String;Lhudson/model/AbstractBuild;Lhudson/Launcher;Lhudson/model/TaskListener;)Lhudson/tasks/junit/TestResult;
      java.lang.NoSuchMethodError: hudson.tasks.junit.JUnitParser.parse(Ljava/lang/String;Lhudson/model/AbstractBuild;Lhudson/Launcher;Lhudson/model/TaskListener;)Lhudson/tasks/junit/TestResult;
      at hudson.plugins.testlink.result.JUnitSuiteNameResultSeeker.seek(JUnitSuiteNameResultSeeker.java:92)
      at hudson.plugins.testlink.TestLinkBuilder.perform(TestLinkBuilder.java:236)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
      at hudson.model.Build$BuildExecution.build(Build.java:199)
      at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      at hudson.model.Run.execute(Run.java:1759)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)

        Attachments

          Activity

          jglick Jesse Glick added a comment -

          TestResultParse.parse was left in with the original signature for compatibility, but evidently that did not help in this case because the call was made against its subclass and so javac linked it that way, and I guess the JVM does not do the obvious thing and treat the call as being inherited. Not sure if there is a good way to write tests for this kind of thing; have to rely on knowledge and code inspection which obviously is not enough.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Jesse Glick
          Path:
          src/main/java/hudson/tasks/junit/JUnitParser.java
          http://jenkins-ci.org/commit/junit-plugin/bf1112f317adb5abb804da4265ae167591655b4a
          Log:
          [FIXED JENKINS-25375] Restore deprecated method override for binary compatibility.

          jglick Jesse Glick added a comment -

          Reporter: I have no easy way of verifying a fix. (Do not even know what Testlink is.) Can you verify against a snapshot build? If so, I can cut a release with the fix. https://jenkins.ci.cloudbees.com/job/plugins/job/junit-plugin/25/org.jenkins-ci.plugins$junit/artifact/org.jenkins-ci.plugins/junit/1.2-beta-4-SNAPSHOT/junit-1.2-beta-4-SNAPSHOT.hpi

          paul01 paul peschel added a comment -

          I test the snapshot and it work success.


            People

            • Assignee:
              jglick Jesse Glick
              Reporter:
              paul01 paul peschel
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: