Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-25427

Build Pipeline Plugin no longer allows starting build with parameters

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: build-pipeline-plugin
    • Labels:
      None
    • Environment:
      Build Pipeline Plugin v1.4.4
    • Similar Issues:

      Description

      I just upgraded from 1.4.3 to 1.4.4 and now it seems like I no longer have to option to start the build pipeline (first job) with parameters which worked in the previous version. In version 1.4.3 when I pressed the "build now" button a modal window appeared where I could select my parameters for the first job. Now it just builds and automatically selects the pre-defined parameter values.

      For us this is critical since the initial job allows the user to select version numbers to download from git branches that are later packaged to a release.

        Attachments

          Issue Links

            Activity

            Hide
            jmiddleton jorge middleton added a comment -

            There is a javascript issue with msie with the current version of fancybox. To fix it, you can use https://github.com/prdolmos/fancybox-1.3.4-patched-for-jquery-1.9

            isIE6 = $.browser.msie && $.browser.version < 7 && !window.XMLHttpRequest

            Jorge

            Show
            jmiddleton jorge middleton added a comment - There is a javascript issue with msie with the current version of fancybox. To fix it, you can use https://github.com/prdolmos/fancybox-1.3.4-patched-for-jquery-1.9 isIE6 = $.browser.msie && $.browser.version < 7 && !window.XMLHttpRequest Jorge
            Hide
            lonefreak Fabricio Leotti added a comment -

            Hello!

            I was facing the same issue using 1.4.8 and Jenkins 1.609.1. I changed the fancybox version to the patched version above and to official version 2.1.5 (http://fancyapps.com/fancybox/). Worked fine in both cases.

            Show
            lonefreak Fabricio Leotti added a comment - Hello! I was facing the same issue using 1.4.8 and Jenkins 1.609.1. I changed the fancybox version to the patched version above and to official version 2.1.5 ( http://fancyapps.com/fancybox/ ). Worked fine in both cases.
            Hide
            anentropic Anentropic added a comment - - edited

            This is broken for me in plugin v1.4.7 using Chrome OSX

            when I click the Run button in the build pipeline view, nothing happens

            I'd like to be able to start a job with parameters

            upgraded to v1.4.8, still broken

            Show
            anentropic Anentropic added a comment - - edited This is broken for me in plugin v1.4.7 using Chrome OSX when I click the Run button in the build pipeline view, nothing happens I'd like to be able to start a job with parameters upgraded to v1.4.8, still broken
            Hide
            wlumetsberger Wolfgang Lumetsberger added a comment -

            This Issue is Still broken see also JENKINS-25430

            Show
            wlumetsberger Wolfgang Lumetsberger added a comment - This Issue is Still broken see also JENKINS-25430
            Hide
            dalvizu Dan Alvizu added a comment -

            Fixed in JENKINS-25430, tracking there. Fixed in master, will be fixed in next release (1.4.9)

            Show
            dalvizu Dan Alvizu added a comment - Fixed in JENKINS-25430 , tracking there. Fixed in master, will be fixed in next release (1.4.9)

              People

              • Assignee:
                dalvizu Dan Alvizu
                Reporter:
                johanhaleby Johan Haleby
              • Votes:
                3 Vote for this issue
                Watchers:
                16 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: