Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26061

Incompatible argument to function

    Details

    • Type: Bug
    • Status: Fixed but Unreleased (View Workflow)
    • Priority: Blocker
    • Resolution: Cannot Reproduce
    • Component/s: other
    • Environment:
      Windows 7 Enterprise
      Jenkins 1.580
      Plugins : Greenballs,deploy. deploy-websphere,mapdb-api, multiple-scms,ws-cleanup
    • Similar Issues:

      Description

      Team,

      My jenkins setup was running succesfully for the last few months and all of a sudden all the jobs started failing when i click "Build Now". Even then, the scheduled jobs were running successfully.

      But since today they also started failing and I am getting the following error in the console output,

      FATAL: (class: org/apache/commons/codec/binary/Base64OutputStream, method: <init> signature: (Ljava/io/OutputStream;ZI[B)V) Incompatible argument to function
      FATAL: (class: org/apache/commons/codec/binary/Base64OutputStream, method: <init> signature: (Ljava/io/OutputStream;ZI[B)V) Incompatible argument to function
      Finished: null

      I am unable to proceed with any build now. Can you please help me?

      P:S I tried adding -Xverify:none option as well.I tried removing the fingerprints directory also.

      Attaching the error log. The time since it started failing is 10/Dec/14-12:00 noon. (if in case you need to know the exact time of failure)

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          It started happening after a restart. Why did you restart, what was changed?

          sakthippm Sakthivel C added a comment -

          There was no change. The builds were working fine until afternoon and all of a sudden the builds started failing. I meant that the restart also didnt help

          slide_o_mix Alex Earl added a comment -

          Is there another Apache Commons jar in your classpath?

          oleg_nenashev Oleg Nenashev added a comment -

          No response to the question from Alex Earl. It is clearly a Binary compat issue somewhere, but there is no recent reports of such kind. Better to close it until somebody hits it again


            People

            • Assignee:
              Unassigned
              Reporter:
              sakthippm Sakthivel C
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: