Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26308

LoadRunner Scenario Always Times Out

    Details

    • Similar Issues:

      Description

      Simple Loadrunner scenario always times out when ran through Jenkins. The test runs fine when started within Loadrunner. Have tried on multiple machines in the same environment and found this issue. Though on my own personal machine it works fine.

      LoadRunner Settings are set to default:
      Controller Polling Interval - 30
      Scenario Execution Timeout - 10
      Errors To Ignore - none

      Below is the console output (notice the timeout occurring at 29 seconds. This is consistent along all attempts):

      Building in workspace C:\Program Files (x86)\Jenkins\jobs\Testing\workspace
      [workspace] $ "C:\Program Files (x86)\Jenkins\jobs\Testing\workspace\HpToolsLauncher.exe" -paramfile props05012015172238713.txt
      "Started..."
      1 tests found:
      C:\Users*****\Downloads\Scenario1.lrs
      ============================================================================
      05/01/2015 17:22:39 Running: C:\Users****\Downloads\Scenario1.lrs
      Cleaning up the environment...
      Preparing scenario C:\Users****\Downloads\Scenario1.lrs for execution.
      Load Generator localhost connected
      Starting scenario...
      Error: Scenario Execution timeout (29 seconds) passed.
      Error: Scenario Execution timeout (

      {0}

      seconds) passed.
      Scenario C:\Users****\Downloads\Scenario1.lrs ended.
      ============================================================================
      Analyzing results...
      Error: Timeout for Analysis passed.
      Analysis Results:

      SLA report:
      ================================
      Full Name : Errors Per Second
      Measurement : ErrorsPerSecond
      CriteriaMeasurement Value : RunningVusers
      LoadThresholds value :
      status : Passed
      ================================

      Error(s) summary:
      0 ignored , 0 errors

      Test PASSED
      Test result: Passed
      05/01/2015 17:24:26 Test complete: C:\Users****\Downloads\Scenario1.lrs
      -------------------------------------------------------------------------------------------------------
      Cleaning up the environment...
      ================================================
      Run status: Job succeeded, total tests: 1, succeeded: 1, failures: 0, errors: 0
      Passed : C:\Users*****\Downloads\Scenario1.lrs
      ================================================
      Report archiving mode is set to: DONT_ARCHIVE_TEST_REPORT
      Finished: SUCCESS

        Attachments

          Activity

          Hide
          connorg Connor Gilbert added a comment -

          Looking through the code, but I'm having difficulty building a version of this app.

          Was hoping to check the _perScenarioTimeOut in waitForScenario(ref string errorReason) in the
          PerformanceTestRunner class.

          It may be a stretch, but I'm trying to check why the timeout is occurring at 29 seconds (which by the way is pretty consistent) rather than the values I set.

          Show
          connorg Connor Gilbert added a comment - Looking through the code, but I'm having difficulty building a version of this app. Was hoping to check the _perScenarioTimeOut in waitForScenario(ref string errorReason) in the PerformanceTestRunner class. It may be a stretch, but I'm trying to check why the timeout is occurring at 29 seconds (which by the way is pretty consistent) rather than the values I set.
          Hide
          connorg Connor Gilbert added a comment - - edited

          Added a $5 bounty

          Show
          connorg Connor Gilbert added a comment - - edited Added a $5 bounty
          Hide
          connorg Connor Gilbert added a comment -

          The issue seems to have been due to Loadrunner 11.52. Problem was fixed after updating to 12.0x. Resolved.

          Show
          connorg Connor Gilbert added a comment - The issue seems to have been due to Loadrunner 11.52. Problem was fixed after updating to 12.0x. Resolved.
          Hide
          connorg Connor Gilbert added a comment -

          Loadrunner version was the issue. Problem fixed.

          Thanks

          Show
          connorg Connor Gilbert added a comment - Loadrunner version was the issue. Problem fixed. Thanks

            People

            • Assignee:
              mrman Avishai Moshka
              Reporter:
              connorg Connor Gilbert
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: