Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26343

Workflow integration for HTMLPublisher

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      HtmlPublisher should be a SimpleBuildStep.

        Attachments

          Issue Links

            Activity

            Hide
            mcrooney mcrooney added a comment -

            I do believe this is taken care of now as of 1.6, please correct me if I'm wrong!

            Show
            mcrooney mcrooney added a comment - I do believe this is taken care of now as of 1.6, please correct me if I'm wrong!
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            This is correct. My bad, I have not updated it

            Show
            oleg_nenashev Oleg Nenashev added a comment - This is correct. My bad, I have not updated it
            Hide
            darrelvun Darrel Vuncannon added a comment -

            Hey Oleg Nenashev or Jesse Glick or anyone:

            Question: Does this integration mean that I cannot use HTMLPublisher unless I have Workflow (aka "Pipeline") installed on my Jenkins? I'd like to use it without, if possible.

            Regards,
            Darrel Vuncannon
            SW Configuration Management and Build Tools Team
            Garmin International

            Show
            darrelvun Darrel Vuncannon added a comment - Hey Oleg Nenashev or Jesse Glick or anyone: Question : Does this integration mean that I cannot use HTMLPublisher unless I have Workflow (aka "Pipeline") installed on my Jenkins? I'd like to use it without, if possible. Regards, Darrel Vuncannon SW Configuration Management and Build Tools Team Garmin International
            Hide
            oleg_nenashev Oleg Nenashev added a comment -

            Hi Darrel,

            The plugin requires only workflow-step-api plugin. This plugin is an API library, which does not provide any UIs or project types. So from the user perspective the instance will have no Pipeline plugin features installed.

            Hopefully it helps

            Show
            oleg_nenashev Oleg Nenashev added a comment - Hi Darrel, The plugin requires only workflow-step-api plugin. This plugin is an API library, which does not provide any UIs or project types. So from the user perspective the instance will have no Pipeline plugin features installed. Hopefully it helps
            Hide
            darrelvun Darrel Vuncannon added a comment -

            Oleg: Yes, that helps a lot. Thanks!

            Show
            darrelvun Darrel Vuncannon added a comment - Oleg: Yes, that helps a lot. Thanks!

              People

              • Assignee:
                oleg_nenashev Oleg Nenashev
                Reporter:
                jglick Jesse Glick
              • Votes:
                5 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: