Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26370

Subversion Plugin 2.5 skips some externals resulting in partial checkout

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.596, Subversion Plugin 2.5
    • Similar Issues:

      Description

      After Subversion Plugin upgraded to 2.5 from 2.4.5, A clean check out strategy(Always Checkout a fresh copy) results in skipping some svn:externals producing a partial checkout without any error and failing down stream builds.

      Reverting to Subversion 2.4.5 fixed the issue.

        Attachments

          Issue Links

            Activity

            srathmann steve rathmann added a comment -

            Experienced this as well. Noticed that externals on the same server were checked out correctly. Only the externals on server with a different domain were skipped in our case.

            willste Steven Williams added a comment -

            Has anyone found a workaround for this issue?

            willste Steven Williams added a comment -

            I believe I was seeing the same issue. We checkout a trunk from one local repository. Then there are 4 different externals being hosted by another sever with its own set of credentials. Using 2.5 it looks like it doesn't even try to build the externals.
            I then tried to check out the external directly by using its repository address and noticed that the credentials were failing to authenticate even though they were valid. When I reverted to 2.4.5 the direct authentication worked with the same set of credentials. So I figured from this the problem is with the authentication process.
            If you download the source for 2.5 and 2.4.5 and compare the file: “SubversionSCM.java” you will see that the calls to svnkit.http.methods were modified to read lib.svnkit.http.methods in version 2.5.
            Reverting this call back to the svnkit.http.methods appears to fix the issue. If you rebuild 2.5 and load it your externals should now authenticate and checkout properly.
            I think in 2.5 there may be a mismatch between the new lib call and the svnkit dependency listed in pom.xml. If you look there for 2.4.5 and 2.5 you will note that they are both using the same svnkit from org.tmatesoft.svnkit. Perhapes that needs to be updated to make lib.svnkit.http.methods work.

            bduffy Brent Duffy added a comment -

            I'm seeing this as well in my setup. With version 2.5, some externals of an SVN URL are just totally ignored during the checkout. I can verify that they are set using ``svn propget svn:externals -R $URL''.

            schristou Steven Christou added a comment -

            Resolving issue as a duplicate of JENKINS-27084. This was fixed in PR 117 and will be made available in the next release.


              People

              • Assignee:
                schristou Steven Christou
                Reporter:
                pdev Prashanth Devarajappa
              • Votes:
                2 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: