Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26493

Use new EC2 API endpoint hostnames

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: ec2-plugin
    • Labels:
      None
    • Environment:
      jenkins: 1.597
      ec2-plugin: 1.24
    • Similar Issues:

      Description

      The EC2 plugin is currently throwing the following error while trying to launch a build slave:

      Jan 19, 2015 5:55:48 PM hudson.plugins.ec2.EC2Cloud provision
      WARNING: Failed to count the # of live instances on EC2
      com.amazonaws.AmazonClientException: Unable to execute HTTP request: eu-central-1.ec2.amazonaws.com: Name or service not known
      

      Performing a resolve directly against the SOA nameservers results in no answer:

      dig eu-central-1.ec2.amazonaws.com @r1.amazonaws.com
      
      ; <<>> DiG 9.9.2-P2 <<>> eu-central-1.ec2.amazonaws.com @r1.amazonaws.com
      ;; global options: +cmd
      ;; Got answer:
      ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33907
      ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 6, ADDITIONAL: 1
      ;; WARNING: recursion requested but not available
      
      ;; OPT PSEUDOSECTION:
      ; EDNS: version: 0, flags:; udp: 4096
      ;; QUESTION SECTION:
      ;eu-central-1.ec2.amazonaws.com.	IN	A
      
      ;; AUTHORITY SECTION:
      ec2.amazonaws.com.	907	IN	NS	ns-911.amazon.com.
      ec2.amazonaws.com.	907	IN	NS	ns-912.amazon.com.
      ec2.amazonaws.com.	907	IN	NS	ns-921.amazon.com.
      ec2.amazonaws.com.	907	IN	NS	ns-923.amazon.com.
      ec2.amazonaws.com.	907	IN	NS	ns-941.amazon.com.
      ec2.amazonaws.com.	907	IN	NS	ns-942.amazon.com.
      
      ;; Query time: 25 msec
      ;; SERVER: 205.251.192.27#53(205.251.192.27)
      ;; WHEN: Mon Jan 19 17:57:13 2015
      ;; MSG SIZE  rcvd: 192
      

      The AWS API docs specify EC2 hostnames like the following:

      ...
      ec2.eu-central-1.amazonaws.com
      ...
      

      So, the "ec2" and "eu-central-1" portions are flipped. I recommend that the API endpoints are updated to use the hostnames that are currently outlined in the API docs.

        Attachments

          Activity

          bbl5660 Brian L added a comment -

          It would be really great to see a new release of this plugin. My team has seen a few issues working with the ec2-plugin, and we're hoping things will get smoother soon. On GitHub, there have been 14 commits to the master branch since the last release (August 2, 2015). One notable change (IMHO), is that the aws-java-sdk dependency has been upgraded from version 1.10.2 (used in the last release) to 1.10.26 (currently in the master branch).

          Can someone please comment as to when an update is expected, or if another plugin should be preferred?

          francisu Francis Upton added a comment -

          Unfortunately there are some regressions in the current master unreleased version. I'm going to try and address those in the next few days and once they are fixed and it seems reliable, I will do a new release.

          nschloe Nico Schlömer added a comment -

          I'd like to second Brian L here and hope that the regressions are smoothed out soon. The new release would save us a great deal of testing time if we can boots the slaves in the same data center as our master.

          francisu Francis Upton added a comment -

          I have finished my work on 1.30 snapshot, I would like some additional testing before I make the release, which I can do any day now.

          francisu Francis Upton added a comment -

          Released in 1.30


            People

            • Assignee:
              francisu Francis Upton
              Reporter:
              jared_biel_bt Jared Biel
            • Votes:
              9 Vote for this issue
              Watchers:
              12 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: