Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2658

Use of images for histograms makes page load very slow

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: warnings-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Every row in a page like in the above URL apparently loads a separate image from
      the server to display the histogram bar, e.g.

      http://deadlock.netbeans.org/hudson/job/test-compilation/lastSuccessfulBuild/warningsResult/category.deprecation/statistics?object=package.org.netbeans.modules.visualweb.jsfsupport.container

      For a large build, it therefore can take several minutes (and plenty of network
      activity and server load) just to display a single bar chart.

      This is silly. Consider using JavaScript and/or CSS to render bars using HTML.

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Duplicate.

            drulli Ulli Hafner added a comment -

            Do you have a suggestion on how to render this with CSS? Please use issue 2429
            for your comments. Thanks, Ulli

                • This issue has been marked as a duplicate of 2429 ***

              People

              • Assignee:
                drulli Ulli Hafner
                Reporter:
                jglick Jesse Glick
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: