Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26704

SEVERE: I/O error in channel Chunked connection to http://localhost:8080/cli

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: cli
    • Labels:
    • Environment:
      Ubuntu 14.04.1 LTS
      Jenkins ver. 1.598
    • Similar Issues:

      Description

      I have problem when I execute Jenkins-cli command
      java -jar jenkins-cli.jar -s http://localhost:8080/ help

      SEVERE: I/O error in channel Chunked connection to http://localhost:8080/cli
      java.io.StreamCorruptedException: invalid stream header: 0A0A0A0A
      at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:804)
      at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
      at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

      Exception in thread "main" hudson.remoting.RequestAbortedException: java.io.StreamCorruptedException: invalid stream header: 0A0A0A0A
      at hudson.remoting.Request.abort(Request.java:295)
      at hudson.remoting.Channel.terminate(Channel.java:814)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      at ......remote call to Chunked connection to http://localhost:8080/cli(Native Method)
      at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
      at hudson.remoting.Request.call(Request.java:171)
      at hudson.remoting.Channel.call(Channel.java:751)
      at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:179)
      at hudson.remoting.$Proxy1.waitForProperty(Unknown Source)
      at hudson.remoting.Channel.waitForRemoteProperty(Channel.java:1200)
      at hudson.cli.CLI.<init>(CLI.java:145)
      at hudson.cli.CLIConnectionFactory.connect(CLIConnectionFactory.java:72)
      at hudson.cli.CLI._main(CLI.java:466)
      at hudson.cli.CLI.main(CLI.java:382)
      Caused by: java.io.StreamCorruptedException: invalid stream header: 0A0A0A0A
      at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:804)
      at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
      at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
      at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Appears to duplicate JENKINS-23223.


              People

              • Assignee:
                Unassigned
                Reporter:
                skratanak sokhom ratanak
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: