Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Linux
    • Similar Issues:

      Description

      Hudson (latest build 1.262). I have a Build multi-configuration project with
      Git as the SCM. After the slave builds are triggered I see:

      started
      Building remotely on debian
      FATAL: Couldn't check for .git
      hudson.plugins.git.GitException: Couldn't check for .git
      at hudson.plugins.git.GitAPI.hasGitRepo(GitAPI.java:53)
      at hudson.plugins.git.GitSCM.checkout(GitSCM.java:129)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:666)
      at
      hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:261)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:235)
      at hudson.model.Run.run(Run.java:817)
      at hudson.matrix.MatrixBuild.run(MatrixBuild.java:100)
      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:90)

      I initially thought this was a permissions problem but after chmod'ing the whole
      Hudson home directory to 0777 I am thinking not. Git is installed locally and I
      can manually clone the repo locally.

        Attachments

          Activity

            People

            • Assignee:
              jbq jbq
              Reporter:
              jamtur01 jamtur01
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: