Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2686

NoSuchMethodError in findbugs plugin 2.20

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      I am running findbugs plugin version 2.20 and hudson 1.200.

      java -version
      java version "1.5.0_15"
      Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04)
      Java HotSpot(TM) Client VM (build 1.5.0_15-b04, mixed mode, sharing)

      Is the findbugs plugin not compatible with this version of hudson?

      java.lang.NoSuchMethodError: hudson.model.Project.getBuilders()Ljava/util/List;
      at
      hudson.plugins.findbugs.util.HealthAwarePublisher.isMavenBuild(HealthAwarePublisher.java:418)
      at hudson.plugins.findbugs.FindBugsPublisher.perform(FindBugsPublisher.java:79)
      at
      ....

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Findbugs 2.20 requires a more recent version of Hudson. Could you please
          update your Hudson, too?

          Currently there is no support for plug-ins to specify a minimum Hudson
          version to run on. You can see the version of a plug-in is built with
          under each project folders:
          https://hudson.dev.java.net/servlets/ProjectDocumentList?folderID=7826&expandFolder=7826&folderID=5818

          klaasjanelzinga klaasjanelzinga added a comment -

          The issue is indeed resolved on 2.62 of Hudson.

          With apologies and thanks,

          KlaasJan


            People

            • Assignee:
              drulli Ulli Hafner
              Reporter:
              klaasjanelzinga klaasjanelzinga
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: