Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-26927

v2.44 of selenium grid jenkins plugin has encoding issues that fails UI automation

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Won't Do
    • Component/s: selenium-plugin
    • Labels:
    • Environment:
      AWS Linux
      3.14.19-17.43.amzn1.x86_64
      FFv25 & FFv31
      Jenkins version 1.598 hosted on AWS Linux
      Selenium Hub/Nodes on AWS Linux
    • Similar Issues:

      Description

      I WAS successfully using this plugin without any issues with the following configuration:
      AWS Linux
      3.14.19-17.43.amzn1.x86_64
      FFv25 & FFv31
      Jenkins version 1.554.2 hosted on AWS Linux
      Selenium Hub/Nodes on AWS Linux
      Selenium Grid plugin version: 2.41
      I upgraded Jenkins to latest in Feb 2015 (v1.598) and the plugin stopped working. Then i got the latest plugin (v2.44) , compiled it locally in Mac Pro and manually added the hpi file to the jenkins.

      The setup (Grid/Node/Jenkins/Plugin) as such was working. But automations were failing because of the following reason:
      The webpages that were opened in FF, the page source were encoded in weird characters especially the <, > and = signs of html.

      Because we rely on these to access certain elements using regexp etc, majority of our automation started failing.

      I downgraded the plugin to the previous version (v2.41) and all started working again.

      Some changes between 2.41 and 2.44 introduced some kind of encoding when Webdriver instances is created or when Browsers are invoked.
      This is blocking me from upgrading to the latest.

        Attachments

          Activity

          Hide
          aragavan ragavan Ambighananthan added a comment -

          Looks like this is related to selenium v2.4.0 and not this plugin
          https://code.google.com/p/selenium/issues/detail?id=8487

          Show
          aragavan ragavan Ambighananthan added a comment - Looks like this is related to selenium v2.4.0 and not this plugin https://code.google.com/p/selenium/issues/detail?id=8487
          Hide
          mobrockers Rouke Broersma added a comment -

          Not an issue with plugin, and fixed by new selenium version.

          Show
          mobrockers Rouke Broersma added a comment - Not an issue with plugin, and fixed by new selenium version.

            People

            • Assignee:
              darkrift Richard Lavoie
              Reporter:
              aragavan ragavan Ambighananthan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: