Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27558

job build fatal error on creating/compressing archive files with a "Failed to parse POMs" message

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      jenkins 1.596.2 lts
      os: Red Hat 4.4.7-9
      jdk: 1.7, 1.8
      container: none
      plugins: standard mix
    • Similar Issues:

      Description

      in creating a simple maven job:

      git clone
      mvn compile package

      i get the following fatal error:

      ERROR: Failed to parse POMs
      de.schlichtherle.truezip.io.InputException: java.io.IOException: java.io.FileNotFoundException: /app/jenkins/workspace/common develop/modules/client/com.foo.analytics/common-client/20150323183039-SNAPSHOT/common-client-20150323183039-SNAPSHOT.pom (No such file or directory)
      at de.schlichtherle.truezip.io.Streams.cat(Streams.java:258)
      at de.schlichtherle.truezip.io.Streams.copy(Streams.java:71)
      at de.schlichtherle.truezip.file.TFile.cp(TFile.java:2744)
      at de.schlichtherle.truezip.file.TFile.cp(TFile.java:2817)
      at org.jenkinsci.plugins.compress_artifacts.ZipStorage.archive(ZipStorage.java:77)
      at org.jenkinsci.plugins.compress_artifacts.CompressingArtifactManager.archive(CompressingArtifactManager.java:50)
      at hudson.maven.MavenBuild$ProxyImpl.performArchiving(MavenBuild.java:483)
      at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.doRun(MavenModuleSetBuild.java:851)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      at hudson.model.Run.execute(Run.java:1759)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:531)
      at hudson.model.ResourceController.execute(ResourceController.java:89)
      at hudson.model.Executor.run(Executor.java:240)

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          Compress Artifacts Plugin, with just 600 installs, is hardly in the "standard mix" of plugins.

          https://wiki.jenkins-ci.org/display/JENKINS/Compress+Artifacts+Plugin

          Please be more specific how to reproduce the issue. Is this a Maven Project, a freestyle project with Maven build step, or freestyle project with shell build step and the two provided commands? From your description, it looks like the latter, but then I wonder why Jenkins would try to archive that file.

          Please read https://wiki.jenkins-ci.org/display/JENKINS/How+to+report+an+issue and follow its instructions.

          jwtodd james todd added a comment -

          i wasn't aware of exactly what plugin was the root cause.

          project: maven with shell-post-process hooks; we also have a number of free-form projects

          i tried every LTS release back to i ran into plugin incompatibility issues, the problem remained.

          i have since co-installed (alongside the broken install) the most resent LTS distro via rpm, and can not reproduce the issue. i am working to migrate over plugins, job confs, etc.

          olivergondza Oliver Gondža added a comment -

          james todd,

          • What version of compress-artifacts are you using?
          • Does the file exist in the workspace after the failure?
          • Can you attach your $JENKINS_URL/job/$JOB_NAME/config.xml?
          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Oliver Gondža
          Path:
          src/test/java/plugins/CompressArtifactsPluginTest.java
          http://jenkins-ci.org/commit/acceptance-test-harness/e8747df2ac1c62e78847f08dcbfd8477902971e5
          Log:
          JENKINS-27558 Reproduce in test

          olivergondza Oliver Gondža added a comment -

          This should be fixed since 1.7.


            People

            • Assignee:
              olivergondza Oliver Gondža
              Reporter:
              jwtodd james todd
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: