Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27618

Workflow support for NUnit plugin

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: nunit-plugin
    • Labels:
    • Environment:
      Jenkins: 1.606, NUnit Plugin: 0.16
    • Similar Issues:

      Description

      Add support for the Workflow plugin by implementing the SimpleBuildStep. https://github.com/jenkinsci/workflow-plugin/blob/master/basic-steps/CORE-STEPS.md#adding-support-from-plugins

        Attachments

          Issue Links

            Activity

            slide_o_mix Alex Earl added a comment -

            Are you sure there are no other TestResult.xml files in the workspace?

            baraghu Raghavendra Bankapur added a comment -

            I too am getting error using this plugin. Below is the error I am seeing.

            Can anyone help?
            java.io.IOException: Could not transform the NUnit report. Please report this issue to the plugin author
            at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:71)
            at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:29)
            at hudson.FilePath.act(FilePath.java:996)
            at hudson.FilePath.act(FilePath.java:974)
            at hudson.plugins.nunit.NUnitPublisher.perform(NUnitPublisher.java:286)
            at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:78)
            at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:65)
            at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1$1.call(SynchronousNonBlockingStepExecution.java:49)
            at hudson.security.ACL.impersonate(ACL.java:221)
            at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution$1.run(SynchronousNonBlockingStepExecution.java:46)
            at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
            at java.util.concurrent.FutureTask.run(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
            Caused by: org.xml.sax.SAXParseException; systemId: file:/D:/CodeFromJenkins/temporary-junit-reports/temp-junit.xml; lineNumber: 2; columnNumber: 3; Content is not allowed in prolog.
            at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
            at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
            at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
            at hudson.plugins.nunit.NUnitReportTransformer.splitJUnitFile(NUnitReportTransformer.java:102)
            at hudson.plugins.nunit.NUnitReportTransformer.transform(NUnitReportTransformer.java:72)
            at hudson.plugins.nunit.NUnitArchiver.invoke(NUnitArchiver.java:66)

            slide_o_mix Alex Earl added a comment -

            Raghavendra Bankapur Please upload your nunit xml files.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Alex Earl
            Path:
            pom.xml
            src/main/java/hudson/plugins/nunit/NUnitArchiver.java
            src/main/java/hudson/plugins/nunit/NUnitPublisher.java
            src/main/java/hudson/plugins/nunit/NUnitReportTransformer.java
            src/main/resources/hudson/plugins/nunit/NUnitPublisher/config.jelly
            src/main/resources/index.jelly
            src/test/java/hudson/plugins/nunit/NUnitArchiverTest.java
            src/test/java/hudson/plugins/nunit/NUnitIntegrationTest.java
            src/test/java/hudson/plugins/nunit/NUnitPublisherTest.java
            src/test/java/hudson/plugins/nunit/NUnitReportTransformerTest.java
            src/test/java/hudson/plugins/nunit/NUnitToJUnitXslTest.java
            src/test/resources/hudson/plugins/nunit/NUnit-issue34452.xml
            http://jenkins-ci.org/commit/nunit-plugin/5bd699cedeae13475a3321637da3d5c47397b362
            Log:
            Fix JENKINS-27618, JENKINS-27906, JENKINS-34452, JENKINS-42967

            slide_o_mix Alex Earl added a comment -

            Will be fixed in 0.19, will no longer need to use step(), you can use just nunit 


              People

              • Assignee:
                slide_o_mix Alex Earl
                Reporter:
                tomppa Tom Hannelius
              • Votes:
                14 Vote for this issue
                Watchers:
                17 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: