Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27630

AssemblyInfo.cs not being changed

    Details

    • Similar Issues:

      Description

      The AssemblyInfo.cs files are not being changed. The version number is being created as far as I can tell. There is nothing in the build log to indicate a problem, I am enclosing a snapshot of how I have the project build configuration set up for change-assembly-version

        Attachments

        1. Capture.PNG
          26 kB
          Douglas Jones
        2. ChangeAssemblyVersionConfig.jpg
          69 kB
          Philipp Strobel

          Activity

          Hide
          phil_ Philipp Strobel added a comment - - edited

          I can also see that the AssemplyInfo.cs was found, but not changed.
          The console printout says it did, but when open the AssemplyInfo.cs file in editor you can see it didn't

          Changing the file(s) **/AssemblyInfo.cs to version : 1.0.0.11
          
          Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend.Tests\Properties\AssemblyInfo.cs, Version : 1.0.0.11
          Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend.Tests\Properties\AssemblyInfo.cs
          Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend\Properties\AssemblyInfo.cs, Version : 1.0.0.11
          Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend\Properties\AssemblyInfo.cs
          Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectIntegration.Tests\Properties\AssemblyInfo.cs, Version : 1.0.0.11
          Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectIntegration.Tests\Properties\AssemblyInfo.cs
          ...
          
          Path To MSBuild.exe: c:\Program Files (x86)\MSBuild\12.0\Bin\MSBuild.exe
          ...
          

          Still the same:

          [assembly: AssemblyVersion("1.0.*")]
          [assembly: AssemblyFileVersion("1.0.*")]
          
          Show
          phil_ Philipp Strobel added a comment - - edited I can also see that the AssemplyInfo.cs was found, but not changed. The console printout says it did, but when open the AssemplyInfo.cs file in editor you can see it didn't Changing the file(s) **/AssemblyInfo.cs to version : 1.0.0.11 Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend.Tests\Properties\AssemblyInfo.cs, Version : 1.0.0.11 Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend.Tests\Properties\AssemblyInfo.cs Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend\Properties\AssemblyInfo.cs, Version : 1.0.0.11 Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectBackend\Properties\AssemblyInfo.cs Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectIntegration.Tests\Properties\AssemblyInfo.cs, Version : 1.0.0.11 Updating file : c:\jenkins\workspace\MyProject-Backend_compile_MSBuild\MyProjectIntegration.Tests\Properties\AssemblyInfo.cs ... Path To MSBuild.exe: c:\Program Files (x86)\MSBuild\12.0\Bin\MSBuild.exe ... Still the same: [assembly: AssemblyVersion( "1.0.*" )] [assembly: AssemblyFileVersion( "1.0.*" )]
          Hide
          phil_ Philipp Strobel added a comment -

          Found my mistake,
          The default RegexPattern is:

          Version[(]\"[\\d\\.]+\"[)]

          But the value of my version also contains a "*" character.
          Changing the RegexPattern to:

          Version\(\"[\d\.\*]+\"\)

          was the solution for me.

          Show
          phil_ Philipp Strobel added a comment - Found my mistake, The default RegexPattern is: Version[(]\ "[\\d\\.]+\" [)] But the value of my version also contains a "*" character. Changing the RegexPattern to: Version\(\ "[\d\.\*]+\" \) was the solution for me.
          Hide
          phil_ Philipp Strobel added a comment -

          May close that issue, since the configuration in Capture.png cant change the AssemblyInfo.cs.
          The Build Step "Change Assempbly Version" is missing.

          Show
          phil_ Philipp Strobel added a comment - May close that issue, since the configuration in Capture.png cant change the AssemblyInfo.cs. The Build Step "Change Assempbly Version" is missing.

            People

            • Assignee:
              Unassigned
              Reporter:
              aeroclassics Douglas Jones
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: