Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27769

Git polling is not detecting changes on BitBucket

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: git-plugin
    • Labels:
      None
    • Environment:
      Ubuntu v14.04
      Jenkins v1.607
      Git Plugin 2.3.5
      Git server is on BitBucket
    • Similar Issues:

      Description

      I have changes pushed BitBucket. Jenkins is configured to poll BitBucket every 5 minutes which works as expected. The problem is that the polling result indicate that there are no changes found.

      This was discovered by coincidence after investigating why a local build break wasn't discovered by Jenkins. We found out that Jenkins job didn't trigger for couple of days.

      When downgrading the git plugin to version 2.3 everything worked.

        Attachments

          Activity

          markewaite Mark Waite added a comment -

          Probably a duplicate of the bug that was introduced in git plugin 2.3.5.

          tle Timo Leinonen added a comment -

          We are experiencing the same issue, but with Atlassian Stash, which is just a local BitBucket I guess.

          markewaite Mark Waite added a comment -

          Timo Leinonen have you attempted to switch from git plugin 2.3.5 to an earlier version to see if that resolves the problem?

          Knowing that will help narrow the range of commits which might have caused the problem.

          tle Timo Leinonen added a comment - - edited

          Yes, sorry for not being more specific. We downgraded to 2.3, like suggested by the reporter, and that fixed the problem.

          tle Timo Leinonen added a comment -

          Tried some other versions, and it seems like 2.3.1 is where the problem is first introduced.

          markewaite Mark Waite added a comment -

          Timo Leinonen the git plugin and git client plugin are being tested in hopes of releasing new versions before the end of June. If you're willing to assist with the testing, please download and install a pre-release build of the git client plugin and the git plugin. Problems detected in the pre-release should be e-mailed to Mark Waite and Nicolas De Loof.

          I wrote some test ideas if you would like suggestions of areas that need testing. The git plugin supports many different use cases and its automated tests only evaluate a very few of those use cases.

          tle Timo Leinonen added a comment -

          Hi Mark Waite
          I tested with the pre-release plugins and it worked perfectly. I did not see any errors or warnings in the logs.

          markewaite Mark Waite added a comment -

          Fix included in git plugin 2.4.0 released 18 July 2015


            People

            • Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              mgalaleldin Mohamed Galal El-Din
            • Votes:
              1 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: