Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28134

Git clone fails since git client plugin 1.17.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: git-client-plugin
    • Labels:
      None
    • Environment:
      Jenkins 1.605
      Ubuntu 14.04 within a docker container
    • Similar Issues:

      Description

      When updating from 1.16.1 to 1.17.0 I suddenly get the following exception when cloning a workspace:

      Cloning the remote Git repository
      remote: Counting objects
      remote: Compressing objects
      Receiving objects
      Resolving deltas
      Updating references
      Checking out Revision 991f2e24d0b9b02801369a4a1297d08b2b923ef8 (origin/master)
      FATAL: String index out of range: -1
      java.lang.StringIndexOutOfBoundsException: String index out of range: -1
      	at java.lang.String.substring(String.java:1955)
      	at hudson.plugins.git.GitChangeSet.isoDateFormat(GitChangeSet.java:179)
      	at hudson.plugins.git.GitChangeSet.parseCommit(GitChangeSet.java:118)
      	at hudson.plugins.git.GitChangeSet.<init>(GitChangeSet.java:89)
      	at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:73)
      	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:67)
      	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:44)
      	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:25)
      	at hudson.scm.ChangeLogParser.parse(ChangeLogParser.java:57)
      	at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:906)
      	at hudson.model.AbstractBuild.access$600(AbstractBuild.java:107)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:621)
      	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:531)
      	at hudson.model.Run.execute(Run.java:1751)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:89)
      	at hudson.model.Executor.run(Executor.java:240)
      

        Attachments

          Issue Links

            Activity

            markewaite Mark Waite added a comment -

            Pavel Batanov either is fine, since it needs to operate correctly with both 1.16.1 and 1.17.0. I'm currently running the pre-release with git client plugin 1.17.0 in my home instance in in my production Jenkins at work. If you're running with 1.16.1, that increases our chances of detecting problems related to version interactions.

            Since the bug was only exposed with git client plugin 1.17.0, you should not see the problem in your configuration. The goal of your testing is to confirm that other things are not broken unexpectedly in the git plugin 2.3.6 release.

            scaytrase Pavel Batanov added a comment -

            Mark, looks working with 1.17.0 and snapshot. I'll write here if I get something broken unexpectedly.

            markewaite Mark Waite added a comment -

            I just had to revert the 2.3.6 snapshot build from my production system with git client plugin 1.17.0 due to non-stop builds. The build runs even though no change should have been detected. More investigation will be needed.

            markewaite Mark Waite added a comment -

            The git client plugin 1.17.1 released 8 May 2015 using the code from git client plugin 1.16.1. That hides the git plugin bug which caused this bug and others.

            Once a simultaneous release of git plugin (master branch) and git client plugin (master branch) can be confirmed that they are reliable, this bug will be resolved. Until then, it is hidden from view, but not resolved.

            markewaite Mark Waite added a comment -

            Fix included in git plugin 2.4.0 released 18 July 2015


              People

              • Assignee:
                ndeloof Nicolas De Loof
                Reporter:
                cbeikov Christian Beikov
              • Votes:
                8 Vote for this issue
                Watchers:
                12 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: