Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28476

Unexpected termination of the channel

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: core, remoting
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.596.2 (installed with apt-get, upgraded from 1.596.1)
      Ubuntu 14.04.1 LTS (Virtualized)
    • Similar Issues:

      Description

      Running a long job (approx. 2 1/2 hrs).
      Slave is also virtualized (on Openstack), started by nodepool and added to jenkins.
      Sometimes (at random, some jobs complete, some take 3 hours, some fail after 1 1/2 hrs) the job ends with the following traceback:

      FATAL: java.io.IOException: Unexpected termination of the channel
      hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.Request.abort(Request.java:295)
      	at hudson.remoting.Channel.terminate(Channel.java:814)
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
      	at ......remote call to d-p-c-local_01-2075(Native Method)
      	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
      	at hudson.remoting.Request.call(Request.java:171)
      	at hudson.remoting.Channel.call(Channel.java:751)
      	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:179)
      	at com.sun.proxy.$Proxy50.join(Unknown Source)
      	at hudson.Launcher$RemoteLauncher$ProcImpl.join(Launcher.java:979)
      	at hudson.tasks.CommandInterpreter.join(CommandInterpreter.java:137)
      	at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:97)
      	at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:66)
      	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
      	at hudson.model.Build$BuildExecution.build(Build.java:199)
      	at hudson.model.Build$BuildExecution.doRun(Build.java:160)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
      	at hudson.model.Run.execute(Run.java:1759)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:89)
      	at hudson.model.Executor.run(Executor.java:240)
      Caused by: java.io.IOException: Unexpected termination of the channel
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
      Caused by: java.io.EOFException
      	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2325)
      	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2794)
      	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:801)
      	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
      	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
      	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
      	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
      

        Attachments

          Activity

          eduardbicerimatei Eduard Biceri-Matei added a comment -

          Slave log:

          <===[JENKINS REMOTING CAPACITY]===>channel started
          Slave.jar version: 2.49
          This is a Unix slave
          Evacuated stdout
          Slave successfully connected and online
          ERROR: Connection terminated
          ha:AAAAWB+LCAAAAAAAAP9b85aBtbiIQSmjNKU4P08vOT+vOD8nVc8DzHWtSE4tKMnMz/PLL0ldFVf2c+b/lb5MDAwVRQxSaBqcITRIIQMEMIIUFgAAckCEiWAAAAA=java.io.IOException: Unexpected termination of the channel
                  at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
          Caused by: java.io.EOFException
                  at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2325)
                  at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2794)
                  at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:801)
                  at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
                  at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
                  at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
                  at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
          ERROR: Socket connection to SSH server was lost
          ha:AAAAWB+LCAAAAAAAAP9b85aBtbiIQSmjNKU4P08vOT+vOD8nVc8DzHWtSE4tKMnMz/PLL0ldFVf2c+b/lb5MDAwVRQxSaBqcITRIIQMEMIIUFgAAckCEiWAAAAA=java.net.SocketException: Connection reset
                  at java.net.SocketInputStream.read(SocketInputStream.java:196)
                  at java.net.SocketInputStream.read(SocketInputStream.java:122)
                  at com.trilead.ssh2.crypto.cipher.CipherInputStream.fill_buffer(CipherInputStream.java:41)
                  at com.trilead.ssh2.crypto.cipher.CipherInputStream.internal_read(CipherInputStream.java:52)
                  at com.trilead.ssh2.crypto.cipher.CipherInputStream.getBlock(CipherInputStream.java:79)
                  at com.trilead.ssh2.crypto.cipher.CipherInputStream.read(CipherInputStream.java:108)
                  at com.trilead.ssh2.transport.TransportConnection.receiveMessage(TransportConnection.java:232)
                  at com.trilead.ssh2.transport.TransportManager.receiveLoop(TransportManager.java:693)
                  at com.trilead.ssh2.transport.TransportManager$1.run(TransportManager.java:489)
                  at java.lang.Thread.run(Thread.java:745)
          Slave JVM has not reported exit code before the socket was lost
          [05/22/15 09:44:07] [SSH] Connection closed.
          
          hushp1pt Tony Wallace added a comment -

          I have much the same log message, from a somewhat older Jenkins (base 1.588, ssh slaves 1.10), on slaves running SLES 11.3. Here, the slave is using the On Demand connection policy (because we are trying different things to help this failure syndrome). So, a build was scheduled for 01:00, the slave started up, all good so far- then the build actually started and then failed immediately.
          Here's the slave log:

          [03/07/16 01:00:25] [SSH] Checking java version of java
          [03/07/16 01:00:32] [SSH] java -version returned 1.7.0.
          [03/07/16 01:00:32] [SSH] Starting sftp client.
          [03/07/16 01:00:32] [SSH] Copying latest slave.jar...
          [03/07/16 01:00:32] [SSH] Copied 439,117 bytes.
          Expanded the channel window size to 4MB
          [03/07/16 01:00:32] [SSH] Starting slave process: cd "/ptmp/jenkins/chapel-ci" && java  -jar slave.jar
          <===[JENKINS REMOTING CAPACITY]===>channel started
          Slave.jar version: 2.47
          This is a Unix slave
          Slave successfully connected and online
          Slave JVM has not reported exit code. Is it still running?
          ERROR: Connection terminated
          java.io.IOException: Unexpected termination of the channel
          	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
          Caused by: java.io.EOFException
          	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2435)
          	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2904)
          	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:883)
          	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:349)
          	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
          	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
          	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
          [03/07/16 01:00:41] [SSH] Connection closed.
          

          Here's the build console log

          Started by timer
          [EnvInject] - Loading node environment variables.
          Building remotely on blahblah01 (xc cf) in workspace /ptmp/jenkins/blahblah/workspace/blahblah-xc
          FATAL: java.io.IOException: Unexpected termination of the channel
          hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
          	at hudson.remoting.Request.abort(Request.java:295)
          	at hudson.remoting.Channel.terminate(Channel.java:814)
          	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
          	at ......remote call to blahblah01(Native Method)
          	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
          	at hudson.remoting.Request.call(Request.java:171)
          	at hudson.remoting.Channel.call(Channel.java:751)
          	at hudson.FilePath.act(FilePath.java:970)
          	at hudson.FilePath.act(FilePath.java:959)
          	at org.jenkinsci.plugins.gitclient.Git.getClient(Git.java:131)
          	at hudson.plugins.git.GitSCM.createClient(GitSCM.java:677)
          	at hudson.plugins.git.GitSCM.createClient(GitSCM.java:669)
          	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1010)
          	at hudson.scm.SCM.checkout(SCM.java:484)
          	at hudson.model.AbstractProject.checkout(AbstractProject.java:1258)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:622)
          	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:528)
          	at hudson.model.Run.execute(Run.java:1759)
          	at hudson.matrix.MatrixBuild.run(MatrixBuild.java:306)
          	at hudson.model.ResourceController.execute(ResourceController.java:89)
          	at hudson.model.Executor.run(Executor.java:240)
          Caused by: java.io.IOException: Unexpected termination of the channel
          	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
          Caused by: java.io.EOFException
          	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2435)
          	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2904)
          	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:883)
          	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:349)
          	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
          	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
          	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
          
          radepal Radosław Palczyński added a comment -

          Same at Jenkins 1.642.2

          Slave log

          [03/26/16 16:26:04] [SSH] Checking java version of java
          [03/26/16 16:26:05] [SSH] java -version returned 1.8.0_51.
          [03/26/16 16:26:05] [SSH] Starting sftp client.
          [03/26/16 16:26:06] [SSH] Copying latest slave.jar...
          [03/26/16 16:26:13] [SSH] Copied 506,667 bytes.
          Expanded the channel window size to 4MB
          [03/26/16 16:26:13] [SSH] Starting slave process: cd "/home/jenkins/node" && java -Xmx1024m -Xms512m -jar slave.jar
          <===[JENKINS REMOTING CAPACITY]===>channel started
          Slave.jar version: 2.53.3
          This is a Unix slave
          Evacuated stdout
          Slave successfully connected and online
          Slave JVM has not reported exit code. Is it still running?
          ERROR: Connection terminated
          ha:AAAAWB+LCAAAAAAAAP9b85aBtbiIQSmjNKU4P08vOT+vOD8nVc8DzHWtSE4tKMnMz/PLL0ldFVf2c+b/lb5MDAwVRQxSaBqcITRIIQMEMIIUFgAAckCEiWAAAAA=java.io.IOException: Unexpected termination of the channel
          	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
          Caused by: java.io.EOFException
          	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2335)
          	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2804)
          	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:802)
          	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
          	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
          	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
          	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
          [03/26/16 16:26:42] [SSH] Connection closed.
          

          Build Log:

          16:26:36 [WS-CLEANUP] Deleting project workspace...
          16:26:38 [WS-CLEANUP] Done
          16:26:41 FATAL: java.io.IOException: Unexpected termination of the channel
          16:26:41 hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
          16:26:41 	at hudson.remoting.Request.abort(Request.java:297)
          16:26:41 	at hudson.remoting.Channel.terminate(Channel.java:847)
          16:26:41 	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
          16:26:41 	at ......remote call to nobel_nmel_ft56_12(Native Method)
          16:26:41 	at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1416)
          16:26:41 	at hudson.remoting.Request.call(Request.java:172)
          16:26:41 	at hudson.remoting.Channel.call(Channel.java:780)
          16:26:41 	at hudson.FilePath.act(FilePath.java:979)
          16:26:41 	at hudson.FilePath.act(FilePath.java:968)
          16:26:41 	at org.jenkinsci.plugins.gitclient.Git.getClient(Git.java:131)
          16:26:41 	at hudson.plugins.git.GitSCM.createClient(GitSCM.java:708)
          16:26:41 	at hudson.plugins.git.GitSCM.createClient(GitSCM.java:700)
          16:26:41 	at hudson.plugins.git.GitSCM.checkout(GitSCM.java:1047)
          16:26:41 	at hudson.scm.SCM.checkout(SCM.java:485)
          16:26:41 	at hudson.model.AbstractProject.checkout(AbstractProject.java:1276)
          16:26:41 	at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:607)
          16:26:41 	at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          16:26:41 	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:529)
          16:26:41 	at hudson.model.Run.execute(Run.java:1738)
          16:26:41 	at hudson.matrix.MatrixRun.run(MatrixRun.java:146)
          16:26:41 	at hudson.model.ResourceController.execute(ResourceController.java:98)
          16:26:41 	at hudson.model.Executor.run(Executor.java:410)
          16:26:41 Caused by: java.io.IOException: Unexpected termination of the channel
          16:26:41 	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
          16:26:41 Caused by: java.io.EOFException
          16:26:41 	at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2335)
          16:26:41 	at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2804)
          16:26:41 	at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:802)
          16:26:41 	at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
          16:26:41 	at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
          16:26:41 	at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
          16:26:41 	at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)
          
          ingunawa Indra Gunawan added a comment -

          Jenkins version: 1.580.3
          SSH Slave plugin version: 1.8
          Master : RHEL 6.2

          Build log:

          Killed by signal 15.
          FATAL: java.io.IOException: Unexpected termination of the channel
          hudson.remoting.RequestAbortedException: java.io.IOException: Unexpected termination of the channel
          at hudson.remoting.Request.abort(Request.java:295)
          at hudson.remoting.Channel.terminate(Channel.java:814)
          at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:69)
          at ......remote call to sym-bld-lnx8(Native Method)
          at hudson.remoting.Channel.attachCallSiteStackTrace(Channel.java:1356)
          at hudson.remoting.Request.call(Request.java:171)
          at hudson.remoting.Channel.call(Channel.java:751)
          at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:173)
          at com.sun.proxy.$Proxy73.join(Unknown Source)
          at hudson.Launcher$RemoteLauncher$ProcImpl.join(Launcher.java:979)
          at hudson.tasks.CommandInterpreter.join(CommandInterpreter.java:137)
          at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:97)
          at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:66)
          at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
          at hudson.model.Build$BuildExecution.build(Build.java:199)
          at hudson.model.Build$BuildExecution.doRun(Build.java:160)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
          at hudson.model.Run.execute(Run.java:1745)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:89)
          at hudson.model.Executor.run(Executor.java:240)
          Caused by: java.io.IOException: Unexpected termination of the channel
          at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:50)
          Caused by: java.io.EOFException
          at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2325)
          at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2794)
          at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:801)
          at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299)
          at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:40)
          at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
          at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:48)

          kshcherban Konstantin Shcherban added a comment -

          Having same issue with AWS ECS docker slaves (https://github.com/jenkinsci/docker-jnlp-slave) and Jenkins 2.32.1 (dockerized)
          Logs from ecs slave

          Jan 27, 2017 3:57:54 PM hudson.remoting.jnlp.Main$CuiListener status
          INFO: Connected
          Jan 27, 2017 4:02:19 PM hudson.remoting.SynchronousCommandTransport$ReaderThread run
          SEVERE: I/O error in channel channel
          java.io.IOException: Unexpected termination of the channel
          #011at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:73)
          Caused by: java.io.EOFException
          #011at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2353)
          #011at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2822)
          #011at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:804)
          #011at java.io.ObjectInputStream.<init>(ObjectInputStream.java:301)
          #011at hudson.remoting.ObjectInputStreamEx.<init>(ObjectInputStreamEx.java:48)
          #011at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
          #011at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:59)
          
          Jan 27, 2017 4:02:19 PM hudson.remoting.jnlp.Main$CuiListener status
          INFO: Terminated
          

          Logs from master

          FATAL: command execution failed
          java.io.IOException: Backing channel 'Channel to /172.16.5.95' is disconnected.
          	at hudson.remoting.RemoteInvocationHandler.channelOrFail(RemoteInvocationHandler.java:191)
          	at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:256)
          	at com.sun.proxy.$Proxy81.isAlive(Unknown Source)
          	at hudson.Launcher$RemoteLauncher$ProcImpl.isAlive(Launcher.java:1043)
          	at hudson.Launcher$RemoteLauncher$ProcImpl.join(Launcher.java:1035)
          	at hudson.tasks.CommandInterpreter.join(CommandInterpreter.java:154)
          	at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:108)
          	at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:65)
          	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
          	at hudson.model.Build$BuildExecution.build(Build.java:205)
          	at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
          	at hudson.model.Run.execute(Run.java:1728)
          	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          	at hudson.model.ResourceController.execute(ResourceController.java:98)
          	at hudson.model.Executor.run(Executor.java:404)
          Caused by: java.io.EOFException
          	at org.jenkinsci.remoting.nio.NioChannelHub$3.run(NioChannelHub.java:617)
          	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at hudson.remoting.SingleLaneExecutorService$1.run(SingleLaneExecutorService.java:112)
          	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
          	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
          	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
          	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          	at java.lang.Thread.run(Thread.java:745)
          Build step 'Execute shell' marked build as failure
          

          172.16.5.95 is one of ip addresses of AWS internal ELB

          lyenliang lyen liang added a comment -

          I also have the same issue with Jenkins 2.32.2. I don't use docker. Both the master and slave nodes are installed directly on windows 10 machines.

           

          FATAL: command execution failed
          02:15:39 java.io.IOException: Backing channel 'Channel to /192.168.100.58' is disconnected.
          02:15:39 at hudson.remoting.RemoteInvocationHandler.channelOrFail(RemoteInvocationHandler.java:191)
          02:15:39 at hudson.remoting.RemoteInvocationHandler.invoke(RemoteInvocationHandler.java:256)
          02:15:39 at com.sun.proxy.$Proxy84.isAlive(Unknown Source)
          02:15:39 at hudson.Launcher$RemoteLauncher$ProcImpl.isAlive(Launcher.java:1043)
          02:15:39 at hudson.Launcher$RemoteLauncher$ProcImpl.join(Launcher.java:1035)
          02:15:39 at hudson.tasks.CommandInterpreter.join(CommandInterpreter.java:154)
          02:15:39 at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:108)
          02:15:39 at hudson.tasks.CommandInterpreter.perform(CommandInterpreter.java:65)
          02:15:39 at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
          02:15:39 at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:779)
          02:15:39 at hudson.model.Build$BuildExecution.build(Build.java:205)
          02:15:39 at hudson.model.Build$BuildExecution.doRun(Build.java:162)
          02:15:39 at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:534)
          02:15:39 at hudson.model.Run.execute(Run.java:1728)
          02:15:39 at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          02:15:39 at hudson.model.ResourceController.execute(ResourceController.java:98)
          02:15:39 at hudson.model.Executor.run(Executor.java:404)
          02:15:39 Caused by: java.io.IOException: 連線嘗試失敗,因為連線對象有一段時間並未正確回應,或是連線建立失敗,因為連線的主機無法回應。
          02:15:39 at sun.nio.ch.SocketDispatcher.read0(Native Method)
          02:15:39 at sun.nio.ch.SocketDispatcher.read(Unknown Source)
          02:15:39 at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source)
          02:15:39 at sun.nio.ch.IOUtil.read(Unknown Source)
          02:15:39 at sun.nio.ch.SocketChannelImpl.read(Unknown Source)
          02:15:39 at hudson.remoting.SocketChannelStream$1.read(SocketChannelStream.java:35)
          02:15:39 at sun.nio.ch.ChannelInputStream.read(Unknown Source)
          02:15:39 at sun.nio.ch.ChannelInputStream.read(Unknown Source)
          02:15:39 at sun.nio.ch.ChannelInputStream.read(Unknown Source)
          02:15:39 at java.io.InputStream.read(Unknown Source)
          02:15:39 at javax.crypto.CipherInputStream.getMoreData(CipherInputStream.java:114)
          02:15:39 at javax.crypto.CipherInputStream.read(CipherInputStream.java:192)
          02:15:39 at hudson.remoting.FlightRecorderInputStream.read(FlightRecorderInputStream.java:86)
          02:15:39 at hudson.remoting.ChunkedInputStream.readHeader(ChunkedInputStream.java:72)
          02:15:39 at hudson.remoting.ChunkedInputStream.readUntilBreak(ChunkedInputStream.java:103)
          02:15:39 at hudson.remoting.ChunkedCommandTransport.readBlock(ChunkedCommandTransport.java:39)
          02:15:39 at hudson.remoting.AbstractSynchronousByteArrayCommandTransport.read(AbstractSynchronousByteArrayCommandTransport.java:34)
          02:15:39 at hudson.remoting.SynchronousCommandTransport$ReaderThread.run(SynchronousCommandTransport.java:59)
          02:15:39 Build step 'Windows PowerShell' marked build as failure

          recampbell Ryan Campbell added a comment -

          This is not an actionable bug, unfortunately. The connection is being interrupted by something unexpected. I've seen this happen due to security intrusion software or load balancers which are proxying the JNLP port.

          Please follow the steps here: https://wiki.jenkins-ci.org/display/JENKINS/Remoting+issue

          I'm closing this as non-reproducible unless you can provide more logs, diangostics or steps to reproduce which can help track down an actual bug instead of just something environmental (the most likely cause in my experience).


            People

            • Assignee:
              Unassigned
              Reporter:
              eduardbicerimatei Eduard Biceri-Matei
            • Votes:
              5 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: