Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28484

Subversion tagging not working - E200015: ISVNAuthentication provider did not provide credentials

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Component/s: subversion-plugin
    • Labels:
    • Environment:
      Jenkins: 1.596.2 (LTS)
      Subversion Plug-in: 2.5
      Credentials Plugin: 1.22
      Subversion Server: 1.8
      Subversion Working Copy: 1.7

      CentOS 6.6 x64, JRE 1.7.0u67, rpm install via stable repo
    • Similar Issues:

      Description

      Tagging https://svn.mediture.com/root/trunk (rev.100666) to https://svn.mediture.com/root/tags/LIFEconnect-179
      ERROR: Failed to tag
      org.tmatesoft.svn.core.SVNCancelException: svn: E200015: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
      svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
          at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:60)
          at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)
          at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:759)
          at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:371)
          at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:359)
          at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.performHttpRequest(DAVConnection.java:710)
          at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.exchangeCapabilities(DAVConnection.java:627)
          at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.open(DAVConnection.java:102)
          at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.openConnection(DAVRepository.java:1032)
          at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.getRepositoryRoot(DAVRepository.java:127)
          at org.tmatesoft.svn.core.internal.wc.SVNCopyDriver.copyReposToRepos(SVNCopyDriver.java:194)
          at org.tmatesoft.svn.core.internal.wc.SVNCopyDriver.setupCopy(SVNCopyDriver.java:627)
          at org.tmatesoft.svn.core.internal.wc16.SVNCopyClient16.doCopy(SVNCopyClient16.java:440)
          at org.tmatesoft.svn.core.internal.wc2.remote.SvnNgReposToReposCopy.run(SvnNgReposToReposCopy.java:65)
          at org.tmatesoft.svn.core.internal.wc2.remote.SvnNgReposToReposCopy.run(SvnNgReposToReposCopy.java:23)
          at org.tmatesoft.svn.core.internal.wc2.SvnOperationRunner.run(SvnOperationRunner.java:21)
          at org.tmatesoft.svn.core.wc2.SvnOperationFactory.run(SvnOperationFactory.java:1259)
          at org.tmatesoft.svn.core.wc2.SvnOperation.run(SvnOperation.java:294)
          at org.tmatesoft.svn.core.wc2.SvnRemoteCopy.run(SvnRemoteCopy.java:227)
          at org.tmatesoft.svn.core.wc.SVNCopyClient.doCopy(SVNCopyClient.java:581)
          at hudson.scm.SubversionTagAction$TagWorkerThread.perform(SubversionTagAction.java:307)
          at hudson.model.TaskThread.run(TaskThread.java:127)
      Caused by: org.tmatesoft.svn.core.SVNCancelException: svn: E200015: ISVNAuthentication provider did not provide credentials; HTTP authorization cancelled.
          at org.tmatesoft.svn.core.internal.io.dav.http.HTTPConnection.request(HTTPConnection.java:689)
          ... 19 more

      I see a request hit apache (svn host), but no request sent to LDAP server. We use basic authentication with an LDAP authentication provider. We don't use variables in the URI or externals. I tried downgrading the subversion plugin, but get a similar error. I also tried deleting $JENKINS_HOME/.subversion. I also tried the SSLv3 only hack without success. I tried global and personal credentials, but ultimately want to use personal credentials. I'm able to authenticate to Subversion with the same credentials during build.

        Attachments

          Issue Links

            Activity

            marqo09 Kyle Hanslovan added a comment - - edited

            I too am running the subversion 2.5.1 plugin and still suffer from the ISVNAuthentication provider error. It appears to only occur when I run a job which checks out a repo with numerous externs. As a temporary work around, I use the "Add additional credentials..." option and specify the exact same creds used to checkout. This band-aid solution mitigates the problem, but something wonky is still going on under the hood.

            Please let me know if you'd like to know any additional information.

            recena Manuel Recena Soto added a comment -

            Kyle Hanslovan, I need a step by step process to reproduce the problem.

            jeanne Jeanne Angeles added a comment -

            Hello, I am having the same issue. Is this fixed? I also have a job that checkouts a repo with multiple externals. I tried using Kyle Hanslovan's workaround, but it does not work for me. As for my setup, Repository depth is set to infinity; Checkout strategy is set to svn "update" as much as possible; Repository URL is pointing to teamforge svn repository. Poll SCM is checked and I have it scheduled to run at 1am. (H 1 * * *)

            Please let me know if you need any other details.

            gameloft_bne_it Morgan Robertson added a comment -

            We are running in to the same issue. The "Add additional credentials..." workaround/fix worked for us. We would get errors such as the following:

            "
            no revision recorded for https://subversionsvr01/vc/repo1/somepath/branches/_dev/whatever/trunk in the previous build
            hudson.util.IOException2: revision check failed on https://subversionsvr02/vc/somelib/sometool/bin/somefile
            "

            I added explicit credentials for the subversionsvr01 repo1 realm. i.e. <https://subversionsvr01:443> Subversion repository repo1

            recena Manuel Recena Soto added a comment -

            Morgan Robertson, Please, file a new issue including a step by step like this in order to reproduce the bug easily.


              People

              • Assignee:
                recena Manuel Recena Soto
                Reporter:
                arthurr Arthur Ramsey
              • Votes:
                9 Vote for this issue
                Watchers:
                19 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: