Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28553

Classic plugin loading with PluginServletFilter can fail to add a Filter even when one jenkins is already initialized

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: core
    • Environment:
    • Similar Issues:

      Description

      When starting jenkins with the JIRA plugin the following NullPointerException is thrown:

      10:29:54,996 INFO  [com.marvelution.jenkins.plugins.jira.JIRAPlugin] (Loading plugin jenkins-jira-plugin) Adding the required filters
      10:29:54,997 SEVERE [jenkins.InitReactorRunner] (pool-12-thread-4) Failed Loading plugin jenkins-jira-plugin: java.io.IOException: Failed to initialize
      	at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:439) [jenkins-core-1.614.jar:]
      	at hudson.PluginManager$2$1$1.run(PluginManager.java:371) [jenkins-core-1.614.jar:]
      	at org.jvnet.hudson.reactor.TaskGraphBuilder$TaskImpl.run(TaskGraphBuilder.java:169) [task-reactor-1.4.jar:]
      	at org.jvnet.hudson.reactor.Reactor.runTask(Reactor.java:282) [task-reactor-1.4.jar:]
      	at jenkins.model.Jenkins$7.runTask(Jenkins.java:905) [jenkins-core-1.614.jar:]
      	at org.jvnet.hudson.reactor.Reactor$2.run(Reactor.java:210) [task-reactor-1.4.jar:]
      	at org.jvnet.hudson.reactor.Reactor$Node.run(Reactor.java:117) [task-reactor-1.4.jar:]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_79]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_79]
      	at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_79]
      Caused by: java.lang.NullPointerException
      	at hudson.util.PluginServletFilter.addFilter(PluginServletFilter.java:99) [jenkins-core-1.614.jar:]
      	at com.marvelution.jenkins.plugins.jira.JIRAPlugin.start(JIRAPlugin.java:78)
      	at hudson.ClassicPluginStrategy.startPlugin(ClassicPluginStrategy.java:447) [jenkins-core-1.614.jar:]
      	at hudson.ClassicPluginStrategy.load(ClassicPluginStrategy.java:436) [jenkins-core-1.614.jar:]
      	... 9 more
      

      https://github.com/jenkinsci/jenkins/pull/1716
      https://marvelution.atlassian.net/browse/JJI-188

        Attachments

          Issue Links

            Activity

            oleg_nenashev Oleg Nenashev added a comment -

            Properly referenced the PR

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Manuel Blechschmidt
            Path:
            core/src/main/java/hudson/util/PluginServletFilter.java
            http://jenkins-ci.org/commit/jenkins/79f99e1e8dec7c27a56267ba480936e5b485e3c2
            Log:
            JENKINS-28553 added more feedback from #1716 pull request

            • documented getInstance
            • used @CheckForNull
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Daniel Beck
            Path:
            core/src/main/java/hudson/util/PluginServletFilter.java
            http://jenkins-ci.org/commit/jenkins/76c1e776569da8f04a78821a551ebd60e9edd3fd
            Log:
            Merge pull request #1716 from ManuelB/jenkins-1.614-branch-JJI-188

            JENKINS-28553 Stable workaround for adding PluginServletFilter

            Compare: https://github.com/jenkinsci/jenkins/compare/a5f704c73ccd...76c1e776569d

            danielbeck Daniel Beck added a comment -

            Manuel Blechschmidt Is this issue resolved by your fix?

            manuel_b Manuel Blechschmidt added a comment -

            Daniel Beck yes the problem is fixed. Sorry for the long response time.


              People

              • Assignee:
                manuel_b Manuel Blechschmidt
                Reporter:
                manuel_b Manuel Blechschmidt
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: