Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28864

Impossible to scroll down Credentials window when opened from inside the Node configuration Page and when selecting ssh credentials

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: credentials-plugin
    • Labels:
    • Environment:
      Jenkins 1.609 and 1.580, Chrome view with 720 px in heigh, 13 inches monitor. Credentials plugin 1.22
    • Similar Issues:

      Description

      To reproduce:

      • create a NODE
      • goto configure NODE
      • from inside the configuration page of the node select SSH node
      • from inside the configuration page of the node select "Add Credentials"
      • from the Credentials form view, select SSH-key type and "insert directly"
      • try to insert a key
      • it is impossible to scroll down to "save" or "cancel" the configuration

      The workaround:

      generate Credentials to be used from the Slave from the main "Credentials" section in the left panel of Jenkins

        Attachments

          Issue Links

            Activity

            danielbeck Daniel Beck added a comment -

            Which versions of the Credentials and SSH Credentials Plugins are you using?

            danielbeck Daniel Beck added a comment -

            This looks like it depends on the height of your browser window. From ~620 px viewport height the buttons disappear in Chrome for me.

            Workaround (besides defining the credentials in the credentials config instead if via this 'Add' button) would be to increase window size.

            danielbeck Daniel Beck added a comment -

            If you're in this situation and need to get out without losing all the slave config, here's how:

            • Select username/password instead to reach the cancel button
            • Cancel
            • Resize the window to larger height
            • Click 'Add' and repeat credentials
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            src/main/resources/com/cloudbees/plugins/credentials/CredentialsSelectHelper/WrappedCredentialsStore/dialog.jelly
            src/main/resources/lib/credentials/select/select.css
            http://jenkins-ci.org/commit/credentials-plugin/6aa38ce350e4ed377decc2e89e23569d2f6cdbcf
            Log:
            [FIXED JENKINS-28864] Impossible to scroll down Credentials window when opened in a small vertical height window


              People

              • Assignee:
                stephenconnolly Stephen Connolly
                Reporter:
                varmenise valentina armenise
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: