Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2891

FATAL: Cannot run program "cleartool" (in directory "M:\ADKLCL1_default_view\ADKLCL1_default_view")

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Incomplete
    • Component/s: clearcase-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: Windows XP
    • Similar Issues:

      Description

      with the following configuration, it is not possible to use an existing CC
      dynamic view to build the project:

      <?xml version='1.0' encoding='UTF-8'?>
      <project>
      <actions class="java.util.concurrent.CopyOnWriteArrayList"/>
      <description></description>
      <logRotator>
      <daysToKeep>70</daysToKeep>
      <numToKeep>100</numToKeep>
      </logRotator>
      <keepDependencies>false</keepDependencies>
      <properties/>
      <scm class="hudson.plugins.clearcase.ClearCaseSCM">
      <viewName>ADKLCL1_default_view</viewName>
      <mkviewOptionalParam></mkviewOptionalParam>
      <filteringOutDestroySubBranchEvent>false</filteringOutDestroySubBranchEvent>
      <useUpdate>false</useUpdate>
      <configSpec># ADKLCL1_ADU_M16_Oxymat7_Labsample_view
      element * CHECKEDOUT
      element * STABLE -nocheckout
      element * /main/puTeam/LATEST
      element * /main/team/LATEST
      element * /main/LATEST
      load \SCPA_CGA_SERIES7_SRC_KHE\COTS\CALC_M16
      load \SCPA_CGA_SERIES7_SRC_KHE\model
      load \SCPA_CGA_SERIES7_SRC_KHE\src
      load \SCPA_CGA_SERIES7_SRC_KHE\test\PCLint
      </configSpec>
      <useDynamicView>true</useDynamicView>
      <viewDrive>M:\ADKLCL1_default_view</viewDrive>
      <branch></branch>
      <vobPaths>SCPA_CGA_SERIES7_SRC_KHE</vobPaths>
      <doNotUpdateConfigSpec>true</doNotUpdateConfigSpec>
      </scm>
      <quietPeriod>55</quietPeriod>
      <canRoam>true</canRoam>
      <disabled>false</disabled>
      <authToken>STABLE</authToken>
      <triggers class="vector">
      <hudson.triggers.TimerTrigger>
      <spec>@daily</spec>
      </hudson.triggers.TimerTrigger>
      </triggers>
      <builders>
      <hudson.tasks.BatchFile>
      <command>@echo #######################
      @rem set SERIES7_VOB_PATH=%CLEARCASE_VIEWPATH%\SCPA_CGA_SERIES7_SRC_KHE
      subst z: /d
      subst z: %CLEARCASE_VIEWPATH%
      @echo hudson-%JOB_NAME%-%BUILD_ID% started
      @echo #######################
      cd %SERIES7_VOB_PATH%
      cleartool catcs
      set "PATH=%CYGWIN_INSTALL_PATH%\bin;%PATH%"
      bash "D:\Programme\Hudson\build_O7_LabSample_ADU.sh" clean
      </command>
      </hudson.tasks.BatchFile>
      </builders>
      <publishers>
      <hudson.plugins.textfinder.TextFinderPublisher>

      <regexp>(\b(Failed|FAILED|FATAL|Fatal|Aborted|aborting)\b)|(\bError[|\bCan't)</regexp>
      <succeedIfFound>false</succeedIfFound>
      <unstableIfFound>false</unstableIfFound>
      <alsoCheckConsoleOutput>true</alsoCheckConsoleOutput>
      </hudson.plugins.textfinder.TextFinderPublisher>
      <hudson.plugins.warnings.WarningsPublisher>
      <threshold></threshold>
      <thresholdEnabled>false</thresholdEnabled>
      <minimumAnnotations>0</minimumAnnotations>
      <healthy></healthy>
      <unHealthy></unHealthy>
      <healthyAnnotations>0</healthyAnnotations>
      <unHealthyAnnotations>0</unHealthyAnnotations>
      <healthyReportEnabled>false</healthyReportEnabled>
      <height></height>
      <pluginName>[WARNINGS] </pluginName>
      <thresholdLimit>low</thresholdLimit>
      <defaultEncoding></defaultEncoding>
      <pattern></pattern>
      <parserNames>
      <string>GNU compiler (gcc)</string>
      <string>MSBuild</string>
      </parserNames>
      </hudson.plugins.warnings.WarningsPublisher>
      <hudson.tasks.Mailer>
      <recipients>claus.klein.ext@siemens.com</recipients>
      <dontNotifyEveryUnstableBuild>true</dontNotifyEveryUnstableBuild>
      <sendToIndividuals>false</sendToIndividuals>
      </hudson.tasks.Mailer>
      </publishers>
      <buildWrappers/>
      </project>

      console log:
      ######################################################
      started
      [workspace] $ cleartool startview ADKLCL1_default_view
      [workspace] $ cleartool catcs -tag ADKLCL1_default_view

      1. ADKLCL1_ADU_M16_Oxymat7_Labsample_view
      2. element * CHECKEDOUT
      3. element * STABLE -nocheckout
        element * .../puTeam/LATEST -nocheckout
        element * .../team/LATEST -nocheckout
        element * /main/LATEST -nocheckout
      4. load \SCPA_CGA_SERIES7_SRC_KHE\COTS\CALC_M16
      5. load \SCPA_CGA_SERIES7_SRC_KHE\model
      6. load \SCPA_CGA_SERIES7_SRC_KHE\src
      7. load \SCPA_CGA_SERIES7_SRC_KHE\test\PCLint
        [ADKLCL1_default_view] $ cleartool lshistory -r -since 20-jan.10:50:18 -fmt
        '\"%Nd\" \"%u\" \"%e\" \"%En\" \"%Vn\" \"%o\" \n%c\n' -nco SCPA_CGA_SERIES7_SRC_KHE
        The directory name is invalid
        FATAL: Cannot run program "cleartool" (in directory
        "M:\ADKLCL1_default_view\ADKLCL1_default_view"): CreateProcess error=267, Der
        Verzeichnisname ist ungültig
        java.io.IOException: Cannot run program "cleartool" (in directory
        "M:\ADKLCL1_default_view\ADKLCL1_default_view"): CreateProcess error=267, Der
        Verzeichnisname ist ungültig
        at java.lang.ProcessBuilder.start(Unknown Source)
        at hudson.Proc$LocalProc.<init>(Proc.java:104)
        at hudson.Proc$LocalProc.<init>(Proc.java:82)
        at hudson.Launcher$LocalLauncher.createLocalProc(Launcher.java:315)
        at hudson.Launcher$LocalLauncher.launch(Launcher.java:306)
        at
        hudson.plugins.clearcase.HudsonClearToolLauncher.run(HudsonClearToolLauncher.java:66)
        at hudson.plugins.clearcase.ClearToolExec.lshistory(ClearToolExec.java:57)
        at
        hudson.plugins.clearcase.base.BaseChangeLogAction.getChanges(BaseChangeLogAction.java:54)
        at
        hudson.plugins.clearcase.AbstractClearCaseScm.checkout(AbstractClearCaseScm.java:251)
        at hudson.model.AbstractProject.checkout(AbstractProject.java:681)
        at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:264)
        at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:238)
        at hudson.model.Run.run(Run.java:842)
        at hudson.model.Build.run(Build.java:88)
        at hudson.model.ResourceController.execute(ResourceController.java:70)
        at hudson.model.Executor.run(Executor.java:90)
        Caused by: java.io.IOException: CreateProcess error=267, Der Verzeichnisname ist
        ungültig
        at java.lang.ProcessImpl.create(Native Method)
        at java.lang.ProcessImpl.<init>(Unknown Source)
        at java.lang.ProcessImpl.start(Unknown Source)
        ... 16 more
        ######################################################

      Im not sure if it is a defect or a missconfiguration.
      The VIEW exist and the VOB is mounted:
      ADKLCL1@ad048214pc /cygdrive/m/ADKLCL1_default_view
      $ ls -lrta
      insgesamt 105
      drwxr-xr-x 9 ADKLCL1 mkgroup-l-d 280 Jan 16 13:19 SCPA_CGA_SERIES7_SRC_KHE
      drwxr-xr-x 3 ADKLCL1 mkgroup-l-d 98304 Jan 20 11:09 ..
      drwxr-xr-x 2 ADKLCL1 mkgroup-l-d 512 Jan 20 11:09 .

      ADKLCL1@ad048214pc /cygdrive/m/ADKLCL1_default_view
      $

      Best regards
      Claus

        Attachments

          Activity

          claus_klein claus_klein added a comment -

          with a slitly changed configuration I get an other problem, see below:

          <?xml version='1.0' encoding='UTF-8'?>
          <project>
          <actions class="java.util.concurrent.CopyOnWriteArrayList"/>
          <description></description>
          <logRotator>
          <daysToKeep>70</daysToKeep>
          <numToKeep>100</numToKeep>
          </logRotator>
          <keepDependencies>false</keepDependencies>
          <properties/>
          <scm class="hudson.plugins.clearcase.ClearCaseSCM">
          <viewName>ADKLCL1_default_view</viewName>
          <mkviewOptionalParam></mkviewOptionalParam>
          <filteringOutDestroySubBranchEvent>false</filteringOutDestroySubBranchEvent>
          <useUpdate>false</useUpdate>
          <configSpec># ADKLCL1_ADU_M16_Oxymat7_Labsample_view

          1. element * CHECKEDOUT
            element * STABLE -nocheckout
          2. element * /main/puTeam/LATEST
          3. element * /main/team/LATEST
          4. element * /main/LATEST
            load \SCPA_CGA_SERIES7_SRC_KHE\COTS\CALC_M16
            load \SCPA_CGA_SERIES7_SRC_KHE\model
            load \SCPA_CGA_SERIES7_SRC_KHE\src
            load \SCPA_CGA_SERIES7_SRC_KHE\test\PCLint
            </configSpec>
            <useDynamicView>true</useDynamicView>
            <viewDrive>M:</viewDrive>
            <branch></branch>
            <vobPaths>SCPA_CGA_SERIES7_SRC_KHE</vobPaths>
            <doNotUpdateConfigSpec>false</doNotUpdateConfigSpec>
            </scm>
            <quietPeriod>55</quietPeriod>
            <canRoam>true</canRoam>
            <disabled>false</disabled>
            <authToken>STABLE</authToken>
            <triggers class="vector">
            <hudson.triggers.TimerTrigger>
            <spec>@daily</spec>
            </hudson.triggers.TimerTrigger>
            </triggers>
            <builders>
            <hudson.tasks.BatchFile>
            <command>@echo #######################
            @rem set SERIES7_VOB_PATH=%CLEARCASE_VIEWPATH%\SCPA_CGA_SERIES7_SRC_KHE
            subst z: /d
            subst z: %CLEARCASE_VIEWPATH%
            @echo hudson-%JOB_NAME%-%BUILD_ID% started
            @echo #######################
            cd %SERIES7_VOB_PATH%
            cleartool catcs
            set "PATH=%CYGWIN_INSTALL_PATH%\bin;%PATH%"
            bash "D:\Programme\Hudson\build_O7_LabSample_ADU.sh" clean
            </command>
            </hudson.tasks.BatchFile>
            </builders>
            <publishers>
            <hudson.plugins.textfinder.TextFinderPublisher>

          <regexp>(\b(Failed|FAILED|FATAL|Fatal|Aborted|aborting)\b)|(\bError[|\bCan't)</regexp>
          <succeedIfFound>false</succeedIfFound>
          <unstableIfFound>false</unstableIfFound>
          <alsoCheckConsoleOutput>true</alsoCheckConsoleOutput>
          </hudson.plugins.textfinder.TextFinderPublisher>
          <hudson.plugins.warnings.WarningsPublisher>
          <threshold></threshold>
          <thresholdEnabled>false</thresholdEnabled>
          <minimumAnnotations>0</minimumAnnotations>
          <healthy></healthy>
          <unHealthy></unHealthy>
          <healthyAnnotations>0</healthyAnnotations>
          <unHealthyAnnotations>0</unHealthyAnnotations>
          <healthyReportEnabled>false</healthyReportEnabled>
          <height></height>
          <pluginName>[WARNINGS] </pluginName>
          <thresholdLimit>low</thresholdLimit>
          <defaultEncoding></defaultEncoding>
          <pattern></pattern>
          <parserNames>
          <string>GNU compiler (gcc)</string>
          <string>MSBuild</string>
          </parserNames>
          </hudson.plugins.warnings.WarningsPublisher>
          <hudson.tasks.Mailer>
          <recipients>claus.klein.ext@siemens.com</recipients>
          <dontNotifyEveryUnstableBuild>true</dontNotifyEveryUnstableBuild>
          <sendToIndividuals>false</sendToIndividuals>
          </hudson.tasks.Mailer>
          </publishers>
          <buildWrappers/>
          </project>

          started
          [workspace] $ cleartool startview ADKLCL1_default_view
          [workspace] $ cleartool catcs -tag ADKLCL1_default_view

          1. ADKLCL1_ADU_M16_Oxymat7_Labsample_view
          2. element * CHECKEDOUT
          3. element * STABLE -nocheckout
            element * .../puTeam/LATEST -nocheckout
            element * .../team/LATEST -nocheckout
            element * /main/LATEST -nocheckout
          4. load \SCPA_CGA_SERIES7_SRC_KHE\COTS\CALC_M16
          5. load \SCPA_CGA_SERIES7_SRC_KHE\model
          6. load \SCPA_CGA_SERIES7_SRC_KHE\src
          7. load \SCPA_CGA_SERIES7_SRC_KHE\test\PCLint
            [workspace] $ cleartool setcs -tag ADKLCL1_default_view
            configspec2998440691704734719.txt
            [ADKLCL1_default_view] $ cleartool lshistory -r -since 20-jan.13:47:52 -fmt
            '\"%Nd\" \"%u\" \"%e\" \"%En\" \"%Vn\" \"%o\" \n%c\n' -nco SCPA_CGA_SERIES7_SRC_KHE
            cleartool: Error: Unable to determine absolute pathname for
            "SCPA_CGA_SERIES7_SRC_KHE" - Permission denied
            cleartool: Error: Unable to access "SCPA_CGA_SERIES7_SRC_KHE": ClearCase object
            not found.
            FATAL: Base ClearCase failed. exit code=1
            FATAL: cleartool did not return the expected exit code. Command line="lshistory
            -r -since 20-jan.13:47:52 -fmt \"%Nd\" \"%u\" \"%e\" \"%En\" \"%Vn\" \"%o\"
            \n%c\n -nco SCPA_CGA_SERIES7_SRC_KHE", actual exit code=1
            java.io.IOException: cleartool did not return the expected exit code. Command
            line="lshistory -r -since 20-jan.13:47:52 -fmt \"%Nd\" \"%u\" \"%e\" \"%En\"
            \"%Vn\" \"%o\" \n%c\n -nco SCPA_CGA_SERIES7_SRC_KHE", actual exit code=1
            at
            hudson.plugins.clearcase.HudsonClearToolLauncher.run(HudsonClearToolLauncher.java:76)
            at hudson.plugins.clearcase.ClearToolExec.lshistory(ClearToolExec.java:57)
            at
            hudson.plugins.clearcase.base.BaseChangeLogAction.getChanges(BaseChangeLogAction.java:54)
            at
            hudson.plugins.clearcase.AbstractClearCaseScm.checkout(AbstractClearCaseScm.java:251)
            at hudson.model.AbstractProject.checkout(AbstractProject.java:681)
            at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:264)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:238)
            at hudson.model.Run.run(Run.java:842)
            at hudson.model.Build.run(Build.java:88)
            at hudson.model.ResourceController.execute(ResourceController.java:70)
            at hudson.model.Executor.run(Executor.java:90)

          But with
          <doNotUpdateConfigSpec>true</doNotUpdateConfigSpec>
          it works?

          Claus

          claus_klein claus_klein added a comment -

          The problem appears after set the ConfigSpec to the view.
          With this simple CS roule:

          element * STABLE -nocheckout

          the VOB basic dir was not visible because it has no STABLE label set.
          This cause the 'cleartool lshistory' cmd to have not a valid CurentWorkingDir
          (CWD) and it fails.

          This happens too if I use the backup roule:

          element * STABLE -nocheckout
          element * /main/LATEST

          because in our VOB, there is no directory version on main branch.

          So the CC plugin Version 0.8.1 with Hudson ver. 1.276 is OK
          This issue can be closed.

          Sorry for the noise.

          Claus

          sunfire sunfire added a comment -

          Closing

          sunfire sunfire added a comment -

          CLOSED


            People

            • Assignee:
              sunfire sunfire
              Reporter:
              claus_klein claus_klein
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: