Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28961

GET/POST with schedule-build-plugin

    Details

    • Similar Issues:

      Description

      after having installed the schedule-build-plugin, if i want to schedule a job without parameters, i have this message:

      You must use POST method to trigger builds. (From scripts you may instead pass a per-project authentication token, or authenticate with your API token.) If you see this page, it may be because a plugin offered a GET link; file a bug report for that plugin.

      and i have to confirm

        Attachments

        1. screenshot-1.png
          screenshot-1.png
          21 kB
        2. screenshot-2.png
          screenshot-2.png
          6 kB
        3. screenshot-3.png
          screenshot-3.png
          10 kB

          Activity

          Hide
          jamesco James Coleman added a comment -

          Upgrading to jenkins 2.7.4 solved the problem for me with CSRF Protection.
          I have now CSRF Protection enabled and Schedule Build Plugin from latest source on github working.

          Show
          jamesco James Coleman added a comment - Upgrading to jenkins 2.7.4 solved the problem for me with CSRF Protection. I have now CSRF Protection enabled and Schedule Build Plugin from latest source on github working.
          Hide
          pingunaut Martin Spielmann added a comment -

          Raphaël UNIQUE this issue is fixed with version 0.4.0-alpha (also for pipelines). Do you have the chance to test this alpha version from the experimental update center?

          Show
          pingunaut Martin Spielmann added a comment - Raphaël UNIQUE this issue is fixed with version 0.4.0-alpha (also for pipelines). Do you have the chance to test this alpha version from the experimental update center?
          Hide
          raphael_unique Raphaël UNIQUE added a comment -

          now, with jenkins 2.601 or 2.46.3:

          • schedule plugin 0.3.4: it now works fine(i don't know why)
          • schedule plugin 0.4.0-alpha: job is not created (after having clicked on the schedule button, the parameter form is not displayed)
          Show
          raphael_unique Raphaël UNIQUE added a comment - now, with jenkins 2.601 or 2.46.3: schedule plugin 0.3.4: it now works fine(i don't know why) schedule plugin 0.4.0-alpha: job is not created (after having clicked on the schedule button, the parameter form is not displayed)
          Hide
          pingunaut Martin Spielmann added a comment -

          Thanks a lot for testing. I was able to reproduce and fix the error (was happening with parameterized jobs)

          0.4.0-alpha2 should fix it.

           

          Show
          pingunaut Martin Spielmann added a comment - Thanks a lot for testing. I was able to reproduce and fix the error (was happening with parameterized jobs) 0.4.0-alpha2 should fix it.  
          Hide
          pingunaut Martin Spielmann added a comment -

          Resolved with version 0.4.0

          Show
          pingunaut Martin Spielmann added a comment - Resolved with version 0.4.0

            People

            • Assignee:
              raphael_unique Raphaël UNIQUE
              Reporter:
              raphael_unique Raphaël UNIQUE
            • Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: