Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29406

git scm reporting failed to connect to repository error and the scm polling no longer works.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: git-plugin
    • Labels:
      None
    • Similar Issues:

      Description

      Anyone seem this issue before?
      Jenkins ver. 1.565.3
      GIT client plugin - 1.17.1
      Git plugin - 2.2.12
      GitHub plugin - 1.11.3
      GitHub pull request builder - 1.20
      GitHub API plugin - 1.67

      Failed to connect to repository : Command "git -c core.askpass=true ls-remote -h git@github.com:xxxxxxxxxxxxxxxxxx.git HEAD" returned status code 128:
      stdout:
      stderr: fatal: failed to stat '.': Permission denied

      — here's the git pollling log —
      Started on Jul 13, 2015 3:01:00 PM
      Using strategy: Default
      [poll] Last Built Revision: Revision ad1ddc6a848d6353c52bb1e3112bcff58a9c68e0 (refs/remotes/xxxxxx/master)
      > git --version # timeout=10
      > git -c core.askpass=true ls-remote -h git@github.com:xxxxxxxxxxxxxxxxxxxxx.git master # timeout=10
      FATAL: hudson.plugins.git.GitException: Command "git -c core.askpass=true ls-remote -h git@github.com:xxxxxxxxxxxxxxxxxxxxx.git master" returned status code 128:
      stdout:
      stderr: fatal: failed to stat '.': Permission denied

      hudson.util.IOException2: hudson.plugins.git.GitException: Command "git -c core.askpass=true ls-remote -h git@github.com:xxxxxxxxxxxxxxxxxxxxx.git master" returned status code 128:
      stdout:
      stderr: fatal: failed to stat '.': Permission denied

      at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:496)
      at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:357)
      at hudson.scm.SCM.poll(SCM.java:374)
      at hudson.model.AbstractProject._poll(AbstractProject.java:1428)
      at hudson.model.AbstractProject.poll(AbstractProject.java:1331)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:477)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:506)
      at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
      at java.util.concurrent.FutureTask.run(FutureTask.java:262)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:744)
      Caused by: hudson.plugins.git.GitException: Command "git -c core.askpass=true ls-remote -h git@github.com:xxxxxxxxxxxxxxxxxxxxx.git master" returned status code 128:
      stdout:
      stderr: fatal: failed to stat '.': Permission denied

      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandIn(CliGitAPIImpl.java:1591)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1379)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1277)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.launchCommandWithCredentials(CliGitAPIImpl.java:1268)
      at org.jenkinsci.plugins.gitclient.CliGitAPIImpl.getHeadRev(CliGitAPIImpl.java:2355)
      at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:530)
      at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:494)
      ... 12 more
      Done. Took 28 ms
      No changes


        Attachments

          Activity

          markewaite Mark Waite added a comment -

          The message

          failed to stat '.': Permission denied

          means that the file system permissions forbid writing to the directory where Jenkins wants to place the git workspace. That is not a bug in the git plugin, that is likely an unexpected change of ownership of a directory in your environment, or an unexpected change of destination directory in the Jenkins job configuration.


            People

            • Assignee:
              ndeloof Nicolas De Loof
              Reporter:
              gsu Guang Su
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: